Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35826 - [cronie] /etc/cron.d/0hourly usePATHthatuse sbin locations

Attached to Project: Arch Linux
Opened by Pablo Lezaeta (Jristz) - Sunday, 16 June 2013, 23:42 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 23 June 2013, 09:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
whit themove of all to usr/bin and the move of all PATHs to point that (alongside usr/local/) this file owned by cronieremain using the old paths
SHELL=/bin/bash
PATH=/sbin:/bin:/usr/sbin:/usr/bin
Ithink for concistency whit Arch decicionis needed to fix that SEHLL and PATH to point only to the needed places (/usr/bin/bash and /usr/bin)
this grant concistency and prebent future problems

Additional info:
* cronie 1.4.9-4


Steps to reproduce:
less /etc/cron.d/0hourly
pacman -Qo /etc/cron.d/0hourly
which bash
less /etc/profile | grep PATH
now compare SHELL and PATHs
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 23 June 2013, 09:33 GMT
Reason for closing:  Won't implement
Additional comments about closing:  cronie-1.4.9-5 in [testing]
Comment by Gaetan Bisson (vesath) - Monday, 17 June 2013, 00:46 GMT
Our policy is not to patch upstream code unnecessarily. The files 0anacron and 0hourly are shipped by upstream, and work perfectly well as-is. Myriads of scripts use #!/bin/sh and we cannot (and should not attempt to) fix them all.
Comment by Pablo Lezaeta (Jristz) - Monday, 17 June 2013, 01:27 GMT
probably can contactupstream, for now this is a 'long time task' becaus ein any moment on the distant future those simlinks are droped (I readthat isnot the time but I not read a definitively no in the mailisting)
and I think (not sure if 100% correctly) a sed command that change the path can by enough, none abouth patch
but yes SHELLcan by (for now) ok, but PATH is redundant and as was mentioning on the mailistin (the public one) for example many paths was changed to a simply (/usr/local/sbin:/usr/local/bin:/usr/bin) and no more
Comment by Gaetan Bisson (vesath) - Monday, 17 June 2013, 01:44 GMT
Do not worry: #!/bin/bash will not stop working anytime soon.
PATH is indeed redundant but that's not worth fixing in my opinion.
Comment by Pablo Lezaeta (Jristz) - Monday, 17 June 2013, 01:49 GMT
in this case,change that PATH in trunk can solve that issue for now ad remove redundantibility (or whatever the word is)

the #!/bin/bash issue ca by changed when the links goig to be removed

in resume: fix only PATH in trunk whit a sed
what about that?
Comment by Gaetan Bisson (vesath) - Monday, 17 June 2013, 02:08 GMT
Why? The PATH works just fine as it is. We don't patch upstream code for pleasure.
Comment by Pablo Lezaeta (Jristz) - Monday, 17 June 2013, 02:14 GMT
because
first is redudat with the actuals simlinks
second that PATH omit usr/local an if I have my own bersion of $(programa) is omither by that script

but... why upstream not give the option to custom that path at build time and prevent patchings??
Comment by Gaetan Bisson (vesath) - Sunday, 23 June 2013, 08:16 GMT
Please feel free to open a feature request upstream.
Comment by Gaetan Bisson (vesath) - Sunday, 23 June 2013, 09:31 GMT
Redundancy is harmless and not a good enough reason to patch upstream's code.

Besides, I see no point making the default PATH "fancier" in /etc/cron.d/0hourly and /etc/anacrontab while leaving it to its current value in processes spawned directly by crond. The latter uses _PATH_DEFPATH from /usr/include/paths.h which is defined to "/usr/bin:/bin" and I am not overriding that in crond's code. If _PATH_DEFPATH gets changed then I will update the aforementioned files accordingly.

In the time being, I will release a new version which adds /etc/cron.d/0hourly to the backup array, so you can customize it if you like.

Loading...