Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35819 - [open-vm-tools] Arch Linux in VMware cannot be suspended or resumed from the host

Attached to Project: Community Packages
Opened by ft1 (ft1) - Sunday, 16 June 2013, 19:21 GMT
Last edited by Sergej Pupykin (sergej) - Tuesday, 18 June 2013, 09:57 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



After installing the open-vm-tools package in a new VMware virtual machine runnung Arch Linux, suspending or resuming the guest OS from the host occasionally fails and error messages show up in the host application.
Apparently the problem is caused by the script '/etc/vmware-tools/scripts/vmware/network' which is executed upon suspend, resume, poweron and poweroff (it's invoked by the different '/etc/vmware-tools/*-vm-default').
This script fails to execute because it's missing the latest changes in Arch Linux. Specifically:

* It is referencing nonexisting '/etc/rc.d/network', the correct location should be '/usr/lib/network/network'
* It is matching network interface names using the regular expression pattern /^eth/. Due to changes in Arch Linux, network interfaces may now have names that are no longer matched by this pattern (my interface is called ens33).
* It relies upon packages that are not listed as dependencies: net-tools (for ipconfig) and networkmanager.

Additional info:
* seen on open-vm-tools 2:9.2.3-3

Steps to reproduce:
* Install fresh Arch Linux in VMware Player or Fusion
* Install open-vm-tools: pacman -S open-vm-tools
* Start the service: systemctl start vmtoolsd
* From the VMware menu, choose suspend.
* If the last step worked well, resume the guest virtual machine.
* An error message saying "The request to Suspend/Resume this virtual machine failed because the corresponding VMware Tools script did not run successfully.".
This task depends upon

Closed by  Sergej Pupykin (sergej)
Tuesday, 18 June 2013, 09:57 GMT
Reason for closing:  Fixed
Comment by Sergej Pupykin (sergej) - Monday, 17 June 2013, 17:12 GMT
I have no arch guest installed, could you please test will attached script work for you?
   network (4.1 KiB)
Comment by ft1 (ft1) - Monday, 17 June 2013, 21:38 GMT
Tested the new script, works like a charm, thanks! Still had to install NetworkManager and net-tools, but then it would run fine.
Comment by Sergej Pupykin (sergej) - Tuesday, 18 June 2013, 09:57 GMT
open-vm-tools-2:9.2.3-5 should work and should not depend on net-tools.