Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#3577 - /etc/pear.conf corrupt in php package

Attached to Project: Arch Linux
Opened by pete (drg006) - Sunday, 04 December 2005, 20:44 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To No-one
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7 Wombat
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

# pear
Notice: unserialize(): Error at offset 91 of 810 bytes in Config.php on line 971ERROR: The default config file is not a valid config file or is corrupted.

You can't run
sed "s|`pwd`||g" -i usr/share/pear/.registry/{console_getopt.reg,archive_tar.reg,pear.reg} etc/pear.conf \
usr/share/pear/{peclcmd.php,pearcmd.php,PEAR/Command/Package.php} usr/bin/{pear,peardev,pecl}
on /etc/pear.conf because it corrupts the file.
Notice that each string is prefixed by its length.
This task depends upon

Closed by  dorphell (dorphell)
Monday, 05 December 2005, 00:33 GMT
Reason for closing:  Duplicate
Comment by pete (drg006) - Sunday, 04 December 2005, 20:51 GMT
duplicate of  FS#3563 
Comment by dorphell (dorphell) - Monday, 05 December 2005, 00:33 GMT
Yeah.. closing this and will continue on that one...

Loading...