Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35749 - [libvirt] libvirtd will not start without KVM or QEMU installed

Attached to Project: Community Packages
Opened by Kevin Loukinen (Hexi) - Monday, 10 June 2013, 19:56 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 09 August 2013, 15:59 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: libvirt 1.0.6-1 - libvirtd will not start without KVM or QEMU installed

After installing LXC, bridge-utils, and libvirt from the official repos, libvirtd will not start. It seems to expect KVM and/or QEMU to be installed. When starting libvirtd (systemctl start libvirtd.service) it does not report an error on the console however libvirtd never starts. Here is the output from "journalctl -xu libvirtd.service":

Jun 10 15:05:29 asgard systemd[1]: Starting Virtualization daemon...
-- Subject: Unit libvirtd.service has begun with start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit libvirtd.service has begun starting up.
Jun 10 15:05:29 asgard systemd[1]: Started Virtualization daemon.
-- Subject: Unit libvirtd.service has finished start-up
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
--
-- Unit libvirtd.service has finished starting up.
--
-- The start-up result is done.
Jun 10 15:05:30 asgard libvirtd[12809]: libvirt version: 1.0.6
Jun 10 15:05:30 asgard libvirtd[12809]: Cannot check dnsmasq binary /sbin/dnsmasq: No such file or directory
Jun 10 15:05:30 asgard libvirtd[12809]: Cannot check dnsmasq binary /sbin/dnsmasq: No such file or directory
Jun 10 15:05:30 asgard libvirtd[12809]: [202B blob data]
Jun 10 15:05:30 asgard libvirtd[12809]: Could not find 'ebtables' executable
Jun 10 15:05:30 asgard libvirtd[12809]: internal error Failed to find path for dmidecode binary
Jun 10 15:05:30 asgard libvirtd[12809]: invalid argument: Failed to parse group 'kvm'
Jun 10 15:05:30 asgard libvirtd[12809]: Initialization of QEMU state driver failed
Jun 10 15:05:30 asgard libvirtd[12809]: Driver state initialization failed

Note that all of those errors are bold white with the exception of "Could not find 'ebtables' executable" which is bold red. I did try to install just ebtables to see if that would allow libvirtd to start even though it's not listed as a hard dependency, but no luck.

Additional info:
* package version(s)
* config and/or log files etc.

libvirt 1.0.6-1

I am trying to use libvirt for LXC only (no KVM or QEMU or other virtualization) and cannot get libvirtd to start. I checked to see if I simply needed to disable an option in /etc/libvirt/libvirtd.conf but there was nothing of the sort. I googled, check bugs here, asked in IRC (both #archlinux on freenode and #virt on OFTC). Folks in #virt did state that KVM/QEMU is not required to run libvirtd.

Steps to reproduce:

Install Arch
Install LXC, bridge-utils, libvirt: pacman -S lxc bridge-utils libvirt
Attempt to start libvirtd: systemctl start libvirtd.service
Check to see if libvirtd is running: ps aux | grep -i virt
Find out why it is not: journalctl -xu libvirtd.service
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 09 August 2013, 15:59 GMT
Reason for closing:  Not a bug
Comment by Sergej Pupykin (sergej) - Friday, 21 June 2013, 11:47 GMT
Will it start if you change group in qemu.conf to existing one?
I think error is "Failed to parse group 'kvm'"
Comment by SABATIER Boris (sababo) - Friday, 02 August 2013, 10:13 GMT
  • Field changed: Percent Complete (100% → 0%)
I have the same problem just after an update.

Some packages aren't link to libvirtd's one like dmidecode, ebtables and dnsmasq.
Comment by Sergej Pupykin (sergej) - Friday, 02 August 2013, 10:24 GMT
Are dmidecode, ebtables and dnsmasq mandatory?

All of them are in optdepends.

I thought reason of failure is "failed to parse group kvm" and other errors are not critical and can be ignored.
Comment by Gustavo Lopes (cataphract) - Friday, 09 August 2013, 15:41 GMT
Commenting out the line:

group="kvm"

in /etc/libvirt/qemu.conf seems to do the trick.

Loading...