Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35720 - [pulseaudio][alsa-utils] Auto-Mute mode disabled by default

Attached to Project: Arch Linux
Opened by Vytenis (DisLike) - Saturday, 08 June 2013, 13:41 GMT
Last edited by Jan Alexander Steffens (heftig) - Wednesday, 12 February 2014, 09:14 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After each update for about a month alsamixer turns Auto-Mute mode back to disabled on my HDA Intel. This causes sound to be played on speakers even if headphones are connected. Turning Auto-Mute mode to enabled manually using alsamixer (by pressing F6 and choosing HDA Intel) solves the problem till next update.

Additional info:
alsa-lib 1.0.27.1-1
alsa-plugins 1.0.27-1
alsa-utils 1.0.27.1-2
pulseaudio-alsa 2-2


Steps to reproduce:
Update alsa-utils.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Wednesday, 12 February 2014, 09:14 GMT
Reason for closing:  Upstream
Comment by Jan Alexander Steffens (heftig) - Sunday, 09 June 2013, 11:37 GMT
Try opening an upstream PulseAudio bug at http://bugs.freedesktop.org
Comment by Vytenis (DisLike) - Sunday, 09 June 2013, 13:22 GMT
I do not believe that bug is related to PulseAudio. More likely it is alsa-utils because alsamixer is part of it. Perhaps it is just the case of overwritting config after update and something wrong about the package itself (unfortunately I do not fully understand how packaging works in regards to configuration so I cannot advise). Currently between updates Auto-Mute does not change and since I turned it on everything still works fine. Let's see what happens with the next update if there is no apparent problem visible.
Comment by Vytenis (DisLike) - Monday, 10 June 2013, 16:42 GMT
Once again alsamixer Auto-Mute got disabled. No idea what disabled it. I performed an update today, but it seems that alsa was not updated during the update... Something keeps reverting the value.

[2013-06-10 00:14] [PACMAN] Running 'pacman -Syu'
[2013-06-10 00:14] [PACMAN] synchronizing package lists
[2013-06-10 00:14] [PACMAN] starting full system upgrade
[2013-06-10 00:22] [PACMAN] upgraded akonadi (1.9.2-1 -> 1.9.2-2)
...
[2013-06-10 00:22] [PACMAN] upgraded archlinux-keyring (20130525-1 -> 20130525-2)
[2013-06-10 00:23] [PACMAN] upgraded kdelibs (4.10.3-3 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded nepomuk-core (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kactivities (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kde-base-artwork (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded oxygen-icons (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-runtime (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdeaccessibility-kmag (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdepim-runtime (4.10.3-2 -> 4.10.4-1)
[2013-06-10 00:23] [ALPM] warning: /usr/share/config/kdm/kdmrc installed as /usr/share/config/kdm/kdmrc.pacnew
[2013-06-10 00:23] [PACMAN] upgraded kdebase-workspace (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded libkexiv2 (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdeartwork-kscreensaver (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-lib (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded nepomuk-widgets (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-dolphin (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-katepart (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-kdepasswd (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-kdialog (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-keditbookmarks (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-kfind (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-konqueror (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-konsole (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-kwrite (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:23] [PACMAN] upgraded kdebase-plasma (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeedu-marble (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded libkipi (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-gwenview (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-kolourpaint (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded libksane (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-ksaneplugin (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-ksnapshot (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-mobipocket (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-okular (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-strigi-analyzer (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-svgpart (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded libkdcraw (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdegraphics-thumbnailers (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded libkcddb (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded libkcompactdisc (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdemultimedia-audiocd-kio (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdemultimedia-kmix (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdepim-libkdepim (4.10.3-2 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdepim-korganizer (4.10.3-2 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdepimlibs (4.10.3-3 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeplasma-addons-applets-showdesktop (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdesdk-kcachegrind (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdesdk-kompare (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeutils-ark (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeutils-filelight (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeutils-kcalc (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [PACMAN] upgraded kdeutils-kwallet (4.10.3-1 -> 4.10.4-1)
[2013-06-10 00:24] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...
[2013-06-10 00:25] [ALPM-SCRIPTLET] >>> Generating initial ramdisk, using mkinitcpio. Please wait...
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Starting build: 3.9.5-1-ARCH
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [autodetect]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux.img
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Starting build: 3.9.5-1-ARCH
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [base]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [udev]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [block]
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: bfa
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [resume]
[2013-06-10 00:25] [ALPM-SCRIPTLET] -> Running build hook: [filesystems]
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Creating gzip initcpio image: /boot/initramfs-linux-fallback.img
[2013-06-10 00:25] [ALPM-SCRIPTLET] ==> Image generation successful
[2013-06-10 00:25] [PACMAN] upgraded linux (3.9.4-1 -> 3.9.5-1)
[2013-06-10 00:25] [PACMAN] upgraded linux-headers (3.9.4-1 -> 3.9.5-1)
[2013-06-10 00:25] [PACMAN] upgraded vlc (2.0.7-1 -> 2.0.7-2)
[2013-06-10 00:25] [PACMAN] upgraded wine (1.5.31-1 -> 1.6rc1-1)
[2013-06-10 00:25] [PACMAN] upgraded wireshark-cli (1.8.7-1 -> 1.10.0-1)
[2013-06-10 00:25] [PACMAN] upgraded wireshark-gtk (1.8.7-1 -> 1.10.0-1)
[2013-06-10 13:38] [PACMAN] Running 'pacman -Syu'
[2013-06-10 13:38] [PACMAN] synchronizing package lists
[2013-06-10 13:38] [PACMAN] starting full system upgrade

Loading...