Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35712 - [libtool] package is out of sync with gcc

Attached to Project: Arch Linux
Opened by Gertjan Halkes (gphalkes) - Saturday, 08 June 2013, 06:47 GMT
Last edited by Allan McRae (Allan) - Monday, 17 June 2013, 01:42 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No



When trying to build C++ shared libraries using libtool, several error messages are produced all similar to:
g++: error: /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/crtbeginS.o: No such file or directory

Libtool is still referring to the 4.8.0 directories, while they no longer exist because gcc has been upgraded to 4.8.1. Simply rebuilding the libtool package on a system with gcc 4.8.1 installed will resolve this issue.

Additional info:
* package version(s)

* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Allan McRae (Allan)
Monday, 17 June 2013, 01:42 GMT
Reason for closing:  Fixed
Additional comments about closing:  libtool-2.4.2-10 in [testing]
Comment by Dave Reisner (falconindy) - Tuesday, 11 June 2013, 15:11 GMT
$ pacman -Si libtool | grep Depends
Depends On : sh libltdl=2.4.2 tar gcc=4.8.1

Would have been quite a feat to build that package without ignoring dependencies... What happens if you reinstall libtool from core?
Comment by Dave Reisner (falconindy) - Tuesday, 11 June 2013, 15:21 GMT
Nevermind, seems like this really wasn't built properly...

$ grep -F 4.8.0 /usr/bin/libtool
sys_lib_search_path_spec="/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0 /usr/lib /lib "
compiler_lib_search_dirs="/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0 /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../../../lib /lib/../lib /usr/lib/../lib /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../.."
predep_objects="/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../../../lib/crti.o /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/crtbeginS.o"
postdep_objects="/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/crtendS.o /usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../../../lib/crtn.o"
compiler_lib_search_path="-L/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0 -L/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../../../lib -L/lib/../lib -L/usr/lib/../lib -L/usr/lib/gcc/x86_64-unknown-linux-gnu/4.8.0/../../.."
Comment by Allan McRae (Allan) - Saturday, 15 June 2013, 13:39 GMT
"Would have been quite a feat to build that package without ignoring dependencies..."\

Not that big a feat if you look at the PKGBUILD...