Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35696 - [bluez] updates broke bluetooth

Attached to Project: Arch Linux
Opened by peter (jqvillanova) - Friday, 07 June 2013, 18:49 GMT
Last edited by Andreas Radke (AndyRTR) - Sunday, 24 November 2013, 11:33 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

Here is the output of `journalctl -xu bluetooth.service' . It refuses to make any bluetooth connection.

[code]
Jun 07 20:32:28 arch bluetoothd[281]: Bluetooth daemon 4.101
Jun 07 20:32:30 arch bluetoothd[281]: Starting SDP server
Jun 07 20:32:30 arch bluetoothd[281]: DIS cannot start: GATT is disabled
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init deviceinfo plugin
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init proximity plugin
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init time plugin
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init alert plugin
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init thermometer plugin
Jun 07 20:32:30 arch bluetoothd[281]: Failed to init gatt_example plugin
Jun 07 20:32:30 arch bluetoothd[281]: Bluetooth Management interface initialized
Jun 07 20:32:31 arch bluetoothd[281]: Unknown command complete for opcode 19
Jun 07 20:32:32 arch bluetoothd[281]: Adapter /org/bluez/281/hci0 has been enabled
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Bluetooth daemon 4.101
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Starting SDP server
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: DIS cannot start: GATT is disabled
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init deviceinfo plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init proximity plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init time plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init alert plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init thermometer plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Failed to init gatt_example plugin
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Bluetooth Management interface initialized
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Unknown command complete for opcode 19
Jun 07 20:32:32 arch bluetoothd[281]: bluetoothd[281]: Adapter /org/bluez/281/hci0 has been enabled
Jun 07 20:33:09 arch bluetoothd[281]: bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/HFPAG
Jun 07 20:33:09 arch bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/HFPAG
Jun 07 20:33:09 arch bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/HFPHS
Jun 07 20:33:09 arch bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/A2DPSource
Jun 07 20:33:09 arch bluetoothd[281]: bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/HFPHS
Jun 07 20:33:09 arch bluetoothd[281]: bluetoothd[281]: Endpoint registered: sender=:1.30 path=/MediaEndpoint/A2DPSource
Jun 07 20:33:42 arch bluetoothd[281]: bluetoothd[281]: Host is down (112)
Jun 07 20:33:42 arch bluetoothd[281]: Host is down (112)
Jun 07 20:34:15 arch bluetoothd[281]: bluetoothd[281]: Host is down (112)
Jun 07 20:34:15 arch bluetoothd[281]: Host is down (112)
Jun 07 20:34:24 arch bluetoothd[281]: bluetoothd[281]: Host is down (112)
Jun 07 20:34:24 arch bluetoothd[281]: Host is down (112)
Jun 07 20:36:51 arch systemd[1]: Started Bluetooth service.
[/code]
Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:

Connect any audio headset in gnome shell with network manager (I guess, at least not blueman)
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Sunday, 24 November 2013, 11:33 GMT
Reason for closing:  Won't fix
Additional comments about closing:  Bleuz4 has been dropped. Please check bluez5 stack.
Comment by Gustavo Alvarez (sl1pkn07) - Friday, 07 June 2013, 19:44 GMT
>Jun 07 20:32:28 arch bluetoothd[281]: Bluetooth daemon 4.101

then is bluez4 instead bluez(5)
Comment by peter (jqvillanova) - Friday, 07 June 2013, 20:23 GMT
Yes it was, sorry. With bluez(5) Service starts just fine, but cannot find any devices (should I reboot?), I reloaded daemons in systemd, restarted the service, but no luck.
Comment by Tom Gundersen (tomegun) - Saturday, 08 June 2013, 08:52 GMT
How does this look like if you enable GTT in /etc/bluetooth/main.conf? (at least there should be fewer warnings)
Comment by max compress (maxcompress) - Sunday, 09 June 2013, 02:30 GMT
/etc/rc.d/bluetooth is missing after update.
and bluetooth gprs connections broken, "rc.d start bluetooth" command not work anymore.
please update packages more carefully.
Comment by Tom Gundersen (tomegun) - Sunday, 09 June 2013, 06:14 GMT
@maxcompress: this is intentional. initscripts are deprecated, please use systemd (sysctl) instead.
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 09 June 2013, 09:13 GMT
I can confirm the problem, after a system update today bluetooth does no longer work for me. I enabled already GATT in /etc/bluetooth/main.conf as suggested, when I try to start the service I got

| Jun 09 10:44:01 mars bluetoothd[1732]: Bluetooth daemon 4.101
| Jun 09 10:44:01 mars bluetoothd[1732]: Starting SDP server
| Jun 09 10:44:01 mars bluetoothd[1732]: Parsing /etc/bluetooth/proximity.conf failed: No such file or directory
| Jun 09 10:44:01 mars bluetoothd[1732]: Not enough free handles to register service
| Jun 09 10:44:01 mars bluetoothd[1732]: Bluetooth Management interface initialized
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Bluetooth daemon 4.101
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Starting SDP server
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Parsing /etc/bluetooth/proximity.conf failed: No such file or directory
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Not enough free handles to register service
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Bluetooth Management interface initialized
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: input-headset driver probe failed for device 00:1D:28:D1:22:65
| Jun 09 10:44:01 mars bluetoothd[1732]: input-headset driver probe failed for device 00:1D:28:D1:22:65
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Adapter /org/bluez/1732/hci0 has been enabled
| Jun 09 10:44:01 mars bluetoothd[1732]: Adapter /org/bluez/1732/hci0 has been enabled
| Jun 09 10:44:01 mars bluetoothd[1732]: bluetoothd[1732]: Unknown command complete for opcode 19
| Jun 09 10:44:01 mars bluetoothd[1732]: Unknown command complete for opcode 19

When I try to connect to a phone device using dolphin and bluedevil I got

| Jun 09 10:44:47 mars obex-data-server[1735]: sdp_extract_seqtype: Unexpected end of packet
| Jun 09 10:45:03 mars obex-data-server[1735]: sdp_extract_seqtype: Unexpected end of packet
| Jun 09 10:45:18 mars obex-data-server[1735]: sdp_extract_seqtype: Unexpected end of packet

I can't install bluez(5) due to broken dependencies on obexd-client (needed by bluedevil) and libbluedevil needs bluez4.

So you any suggestion how to solve the problem with bluez4-4.101-1 or how to downgrade to a working bluez-4.101-1 would be welcome.
Comment by Francesco Di Nardo (angelsoul) - Sunday, 09 June 2013, 15:59 GMT
I can confirm the problem. After system update bluetooth doesn't work.
I use gnome-bluetooth which has bluez4 as dependence, so i can't install bluez(5)

i enabled GATT in /etc/bluetooth/main.conf and if i start the service (bluetooth.service) the result is:
[code]
-- The start-up result is done.
giu 09 17:53:52 dellst bluetoothd[6702]: bluetoothd[6702]: Parsing /etc/bluetooth/proximity.conf failed: No such file or directory
giu 09 17:53:52 dellst bluetoothd[6702]: bluetoothd[6702]: Not enough free handles to register service
giu 09 17:53:52 dellst bluetoothd[6702]: bluetoothd[6702]: Bluetooth Management interface initialized
giu 09 17:53:52 dellst bluetoothd[6702]: Parsing /etc/bluetooth/proximity.conf failed: No such file or directory
giu 09 17:53:52 dellst bluetoothd[6702]: Not enough free handles to register service
giu 09 17:53:52 dellst bluetoothd[6702]: Bluetooth Management interface initialized
giu 09 17:53:56 dellst systemd[1]: Started Bluetooth service.
-- Subject: Unit bluetooth.service has finished start-up
-- Defined-By: systemd
--
-- Unit bluetooth.service has finished starting up.
--
-- The start-up result is done.
[/code]

It seems like work fine, but the bluetooth not is detected from gnome-bluetooth.
Comment by João Paulo (leduck) - Tuesday, 11 June 2013, 01:35 GMT
I'm having the same problem here. And there are several reports on the internet about this problem.
Comment by Tom Gundersen (tomegun) - Tuesday, 11 June 2013, 16:36 GMT
Could someone who is experincing this problem please paste logs from bluez4-4.101 and also when downgrading to bluez-4.101 so we can see the difference? They should in principle be identical.
Comment by João Paulo (leduck) - Tuesday, 11 June 2013, 16:55 GMT
Right now I downgrade to gnome-bluetooth v3.8.1 and bluez v4.101-2 and everything is working perfectly. My system is clean (was installed on Sunday) if you tell me exactly what you need and how to do, I will gladly help. Can I get the log, upgrade to the current versions of bluez4 and gnome-bluetooth and pick up the log again to compare.
Comment by Tom Gundersen (tomegun) - Tuesday, 11 June 2013, 17:58 GMT
First upgrade only gnome-Bluetooth to verify that the problem is with Bluez. You will need to ignore dependencies to avoid pulling in Bluez4.

Of that works, please record the logs before reinstalling gnome-Bluetooth and hence pulling in the new dependencies. Finally record the new log and post both.
Comment by João Paulo (leduck) - Tuesday, 11 June 2013, 18:08 GMT
Which log, how to catch? I updated gnome-bluetooth to version 3.8.1-2 and the system keeps running.
Comment by Tom Gundersen (tomegun) - Tuesday, 11 June 2013, 18:29 GMT
Please reboot between the upgrades.
Comment by João Paulo (leduck) - Wednesday, 12 June 2013, 13:34 GMT
My installation is clean and contains no personal document, so if you want, I can give remote access to my machine for you to do an analysis and make the necessary tests.
Comment by Heinrich Siebmanns (Harvey) - Wednesday, 12 June 2013, 15:17 GMT
Maybe related to what I found out. I had several systems that did not work after updates to bluetooth. 'hciconfig --all' gave me the hint: The adapter starts powered down. After executing 'hciconfig hci0 up' as root all is well for me.
Comment by Francesco Di Nardo (angelsoul) - Wednesday, 12 June 2013, 16:37 GMT
I don't know if its related, but in my system hciconfig --all doesn't show anything.

EDIT:
i haven't restarted :D
After restart all works fine.
Comment by Heinrich Siebmanns (Harvey) - Wednesday, 12 June 2013, 16:40 GMT
hciconfig is now part of bluez-utils, you have to install the package first.
Comment by Martin Schnitkemper (Martin-MS) - Wednesday, 12 June 2013, 17:15 GMT
hciconfig --all shows my adapter, that is not the problem. My problem is, that after the recent update I cannot search the device with dolphin to show the files. I can connect and a filetransfer from or to the phone device works for me, but no longer the search.

For those who have to bring up the adapter as root: I had an entry for myself in /etc/dbus-1/system.d/bluetooth.conf. This file has been renamed during the last update to bluetooth.conf.pacsave and replaced by the bluetooth.conf of the installation package. I expect that the installer left it untouched and place a bluetooth.conf.pacnew in the folder, as usual. However, it might help if you duplicate the "root"-section and rename it to the user you sign on with.
Comment by Joël Schaerer (lardon) - Wednesday, 12 June 2013, 20:57 GMT
Could the problem be that bluez-utils is needed? In my case I installed it and restarted, and now everything works fine.
Comment by Tom Gundersen (tomegun) - Wednesday, 12 June 2013, 21:03 GMT
I'm not able to reproduce this bug even with bluez-utils uninstalled, but lardon might still be right. Can anyone reproduce the problem with bluez-utils installed?
Comment by Martin Schnitkemper (Martin-MS) - Wednesday, 12 June 2013, 21:21 GMT
Nice try, but an installed bluez-utils changes nothing for me:

| Jun 12 23:12:22 mars bluetoothd[1178]: Adapter /org/bluez/1178/hci0 has been enabled
| Jun 12 23:12:22 mars bluetoothd[1178]: bluetoothd[1178]: Unknown command complete for opcode 19
| Jun 12 23:12:22 mars bluetoothd[1178]: bluetoothd[1178]: Adapter /org/bluez/1178/hci0 has been enabled
| Jun 12 23:13:24 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet
| Jun 12 23:13:40 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet
| Jun 12 23:13:56 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet
| Jun 12 23:14:12 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet
| Jun 12 23:14:28 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet
| Jun 12 23:14:45 mars obex-data-server[1187]: sdp_extract_seqtype: Unexpected end of packet

dolphin says "Device busy, please wait" while the progressbar moving for- and backward and frequently report the "Unexpected end of packet" message.
Comment by João Paulo (leduck) - Wednesday, 12 June 2013, 21:24 GMT
For me also solved with bluez-utils. Tom, I realized that the difference between the old bluez version 4, and the new bluez4 is just the files that are in packages bluez-utils and bluez-libs. Would not it be interesting to put them as a dependency? Another thing, the package bluez-utils and bluez-libs Version 5 is the same or are the same files for version 4?
Comment by Tom Gundersen (tomegun) - Wednesday, 12 June 2013, 21:48 GMT
@leduck: as this seems to solve at least some problem I'll add the dependency.

@Martin-MS: the errors you are seeing appears to be different from the other people. Could you open a separate report for that?
Comment by João Paulo (leduck) - Thursday, 13 June 2013, 19:43 GMT
Tom, any idea when you upgrade bluez4 dependence with bluez-utils?
Comment by Tom Gundersen (tomegun) - Thursday, 13 June 2013, 19:55 GMT
In testing now.
Comment by Joël Schaerer (lardon) - Friday, 14 June 2013, 20:19 GMT
I'm still having problems, even with bluez-utils installed. I've been trying the EnableGATT option in /etc/bluetooth.d/main.conf, which seems to have a positive effect. Unfortunately I don't have time to perform exhaustive testing now.
Comment by Martin Schnitkemper (Martin-MS) - Sunday, 16 June 2013, 08:22 GMT
@tomegun: I don' t know for which package I should file a separate report.
I downgraded today to libbluedevil-1.9.3-1, bluez-4.101-1, obexd-client-1:0.46-1 and removed bluez-libs-5.5-3 and bluez-utils-5.5-3. No progress so far, I can't still search the device using the dolphin filemanager.
It could also be an issue with kde4, since I upgraded the same day kde from 4.10.3 to 4.10.4, since it seems that the problem only appears with dolphin; and users with gnome had no problems and I can also transfer single files up the phone device if I use the bluedevil-plugin or if I start the transfer from the phone.

[Edit]
This https://bbs.archlinux.org/viewtopic.php?id=165186 describe exactly the problem that I have, too. Since obexftp works for him it looks like an issue with the last upgrade to kde-4.10.4, no solution available so far.

Loading...