Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35670 - [linux] 3.9.x ACPI no longer detects battery after update

Attached to Project: Arch Linux
Opened by Scott H (scott_fakename) - Thursday, 06 June 2013, 06:09 GMT
Last edited by Tobias Powalowski (tpowa) - Saturday, 15 June 2013, 07:48 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I am running arch on a toshiba satellite. A while ago I updated the kernel using pacman to version 3.9.2-1, and when I rebooted, I noticed that XFCE no longer displayed battery information (only the AC adapter) even when I'm not plugged in to the wall. running 'acpi -v' shows no information about batteries. Prior to the update, the battery was detected without issue. A further upgrade in the kernel (currently I'm running 3.9.4-1) did not see a fix.

When I posted about it on the forum, at least two other people seemed to be having the same issue.

Additional info:
* Kernel version 3.9.2-1 and up appear to be at fault.
* There is a forum post with many more details at https://bbs.archlinux.org/viewtopic.php?id=163223
* More information can be provided on request.

Steps to reproduce:
Buy toshiba satellite.
Upgrade kernel.
Attempt to look at battery information.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Saturday, 15 June 2013, 07:48 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Thursday, 06 June 2013, 06:13 GMT
Please report upstream.
Comment by Scott H (scott_fakename) - Thursday, 06 June 2013, 08:19 GMT
Done
Comment by Tobias Powalowski (tpowa) - Thursday, 06 June 2013, 10:39 GMT
Please link upstream report here.
Comment by Scott H (scott_fakename) - Thursday, 06 June 2013, 16:18 GMT
Oh sorry. I thought you meant "let them deal with it." never done this before. Anyway here's the link: https://bugzilla.kernel.org/show_bug.cgi?id=59361
Comment by Scott H (scott_fakename) - Saturday, 15 June 2013, 07:23 GMT
By compiling a kernel myself I was able to get battery and "fn" keys detected after adding some things to the .config file. While running that custom compiled kernel, I updated to the latest version of linux in arch's repos. As of now, the arch version seems to be detecting everything fine.

Loading...