Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35664 - [lib32-nss] Missing values in /usr/lib32/pkgconfig/nss.pc

Attached to Project: Community Packages
Opened by kozec (kozec) - Wednesday, 05 June 2013, 21:13 GMT
Last edited by Laurent Carlier (lordheavy) - Saturday, 08 June 2013, 14:20 GMT
Task Type Bug Report
Category Packages: Multilib
Status Closed
Assigned To Laurent Carlier (lordheavy)
Daniel Wallace (gtmanfred)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
There are two lines in nss.pc file seemingly breaking build of anything, that depends on lib32-nss and uses pkg-config.

Problems are caused by lines:
Version:
Requires: nspr >=

Errors reported:
1. Comparison operator but no version after package name 'nspr' in file '/usr/lib32/pkgconfig/nss.pc'
2. Requested 'nss >= 3.11' but version of NSS is

(note empty version strings in both pc file and error messages)

Changing both lines to:
Version: 3.14
Requires: nspr >= 4.9
... fixes poblem
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Saturday, 08 June 2013, 14:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  lib32-nss 3.14.3-2

Loading...