Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35644 - [gkrellm] dumps core

Attached to Project: Community Packages
Opened by Geoff (perseus) - Tuesday, 04 June 2013, 16:42 GMT
Last edited by György Balló (City-busz) - Wednesday, 25 December 2013, 09:39 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Laurent Carlier (lordheavy)
Architecture All
Severity Medium
Priority Normal
Reported Version 2.2.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

I am guessing that bug this is probably upstream or specific to my machine and/or configuration, but I will report it here in case I am wrong. The gkrellm mailing list seems to be down and the developer has not yet responded to an e-mail sent a few days ago.

gkrellm has been reliable on this machine (using icewm as my WM), for about 5 years. In the past month or so it has begun to crash and dump core. There have been no changes to my system in that time except for the daily 'pacman -Syu' Sometimes this happens after hours of starting gkrellm, sometimes after days. Generally it is after 3 or 4 hours. When runniing from an xterm, the last line is:

aborted: Sensors (update_monitor)
Aborted (core dumped)

I am inexpert, but I have tried running under gdb. It never crashes when I do this.

I have also run using the script command with a 2>&1 session. The output after the most recent crash is at the top of the attached gkrellm.txt. The crash also leaves a lot of output in the xterm, much of which has probably scrolled off. What I can still see is the second part of gkrellm.txt.

I don't want to make this report overlong. If someone tells me what else may be needed, I will (of course), respond.

Additional info:
* package version(s) 2.3.5-4
* config and/or log files etc - attached gkrellm.txt


Steps to reproduce: Simply run the program and wait.
This task depends upon

Closed by  György Balló (City-busz)
Wednesday, 25 December 2013, 09:39 GMT
Reason for closing:  Upstream
Comment by Jelle van der Waa (jelly) - Thursday, 06 June 2013, 20:06 GMT
Do you have a specific config, cause the plain gkrellm version works fine here
Comment by Geoff (perseus) - Thursday, 06 June 2013, 20:40 GMT
I think is is fairly simple config - I have not changed it for years. I use the default theme. I have the mailwatch plugin (which has not changed since 2007).
I have put my user_config & sensor_config in the attached configs.txt

The last crash occured after 12 hours of gkrellm uptime (this box is on 24/7). As usual it occurred randomly (so far as I an tell), when I had been away from the machine for hours.

I have gone back to running under gdb - starting 12 hours ago. So far there has been no crash - but I have never had a crash while running under gdb. I don't know what to look for in the non-crash output of gdb - what I see is an endless sequence of "New Thread" .. eg :

[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0xb2e74b40 (LWP 11249)]
[Thread 0xb2e74b40 (LWP 11249) exited]
[New Thread 0xb2e74b40 (LWP 11252)]
[Thread 0xb2e74b40 (LWP 11252) exited]

... etc (the current total is > 19,000 of these/

It occurs to me that the problem may have started when lm_sensors was updated on 12th May (there has been subsequent update, as you will know). I only keep the last two versions of packages, but I could try finding / installing the previous one if that might help.
Comment by Jelle van der Waa (jelly) - Friday, 07 June 2013, 20:03 GMT
Please report this bug upstream.
Comment by Geoff (perseus) - Friday, 07 June 2013, 20:16 GMT
I tried (email to the dev a week ago). No reply. It seems that gkrellm is no longer being developed or fixed. I am playing with conky now. Incidentally, no crash of gkrellm after 24 hours of running under gdb. As I said, it never crashes when run like that. Thanks for trying to help. Do you want me to request closure of this bug - or just do it yourself when you are ready?
Comment by Xavion (Xavion) - Saturday, 13 July 2013, 09:34 GMT
  • Field changed: Percent Complete (100% → 0%)
I'm also facing this problem. A workaround is to launch it via "gkrellm --without-libsensors".

According to the README file, an alternative is to build it via "make without-libsensors=yes".
Comment by Sven-Hendrik Haase (Svenstaro) - Saturday, 13 July 2013, 10:32 GMT
Reopening to discuss dropping of gkrellm. I would +1 that.
Comment by Xavion (Xavion) - Saturday, 13 July 2013, 22:19 GMT
Further testing has revealed that the first workaround I mentioned above isn't perfect. It definitely seems to lessen the frequency of the crashes, but it doesn't stop them from occurring altogether. I'm guessing the second workaround I noted would probably have the same impact.

If you decide to shift this package back to the AUR, please notify me after doing so and I'll adopt it.
Comment by John Davis (netskink) - Wednesday, 16 October 2013, 00:43 GMT
Hello

I have a similar situation. Gkrellm was working fine and recently it started dumping core for me. Sometimes within a few minutes of starting it.

Oct 15 17:18:10 t61p systemd-coredump[1979]: Process 1858 (gkrellm) dumped core.
-- Subject: Process 1858 (gkrellm) dumped core
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: man:core(5)
--
-- Process 1858 (gkrellm) crashed and dumped core.
--
-- This usually indicates a programming error in the crashing program and
-- should be reported to its vendor as a bug.

I would prefer you guys don't drop it. I can write some code, if possible I'll help. I guess the first thing I could do is find the core file and see if I can back trace it. Any idea where I could find it? find / -name core?
Comment by Vince Radice (vhradice) - Saturday, 19 October 2013, 16:56 GMT
I am having the same problem - gkrellm crashes without notice. I am running Fedora - not Arch. But I do know when the problem started. I had just upgraded from Fedora 17 to FC19. I think that there was probably a kernel update involved in the upgrade. My kernel is linux 3.10.11-200.fc19.x86_64. I can find the core dump from my system if it will help. When I try to report the error using the Automatic Bug Reporting Tool (abrt), the reporting fails because the backtrace is unusable.

Please let me know if I can help fix this.
Comment by John Davis (netskink) - Tuesday, 22 October 2013, 21:45 GMT
For what it is worth. I've noticed that I seldom if ever have a problem with gkrellm on my laptop, if I boot with power supply connected and maintain the power supply connection until shutdown. However, if I am swapping the power supply connection off and on, it seems to exacerbate the problem with gkrellm crashing.
Comment by Laurent Carlier (lordheavy) - Sunday, 27 October 2013, 06:49 GMT
Are you everybody with Nvidia proprietary drivers ?

No problems here with ati/mesa drivers
Comment by Geoff (perseus) - Sunday, 27 October 2013, 08:22 GMT
Yes Laurent, Nvidia.
Comment by Xavion (Xavion) - Sunday, 27 October 2013, 09:31 GMT
Yes, I'm also using Nvidia's proprietary drivers. No battery is attached to this desktop computer.
Comment by John Davis (netskink) - Sunday, 27 October 2013, 16:20 GMT
I'm using nvidia. And it definitely seems to be a problem with running on battery.
Comment by Manuel Bua (manuel) - Friday, 01 November 2013, 17:48 GMT
I'm on nVidia, no battery here, it just keep crashing at random intervals..

Loading...