Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35637 - [monodevelop] Could not connect to the debugger

Attached to Project: Arch Linux
Opened by Pavlos Touboulidis (pav) - Tuesday, 04 June 2013, 09:54 GMT
Last edited by Antonio Rojas (arojas) - Wednesday, 25 October 2017, 16:32 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For some time now, debugging with MonoDevelop does not work. Trying to debug even the simplest console application gives the following error:

"Could not connect to the debugger".
"debugger-agent: Unable to connect to 127.0.0.1:40904" (port is random)

Additional info:
Sorry, I can't recall at what version this started happening but we're at 4.0.8-1 now.

I don't think it's related to the version of mono that's installed, since I get the same error consistently with mono 2.9.10, 3.0.7 or 3.0.12 (git).

And here's the output from the log file:

ERROR [2013-06-04 12:36:18Z]: Error in debugger
Mono.Debugging.Soft.ConnectionException: Could not connect to the debugger. ---> System.Net.Sockets.SocketException: interrupted
at System.Net.Sockets.Socket.Accept () [0x0006d] in /build/mono/src/mono-3.0.7/mcs/class/System/System.Net.Sockets/Socket.cs:553
at Mono.Debugger.Soft.VirtualMachineManager.LaunchInternal (ITargetProcess p, System.Diagnostics.ProcessStartInfo info, System.Net.Sockets.Socket socket) [0x00004] in /build/monodevelop/src/monodevelop-4.0.8/main/contrib/Mono.Debugger.Soft/Mono.Debugger.Soft/VirtualMachineManager.cs:49
--- End of inner exception stack trace ---

Steps to reproduce:
* Start MonoDevelop
* Open/create any C# application
* Start debugging

P.S. Someone else is having the same problem over at stackoverflow: http://stackoverflow.com/questions/16866207/unable-to-hit-breakpoints-in-monodevelop
This task depends upon

Closed by  Antonio Rojas (arojas)
Wednesday, 25 October 2017, 16:32 GMT
Reason for closing:  Won't fix
Additional comments about closing:  monodevelop has been dropped
Comment by Butcher Blues (Butcher) - Tuesday, 04 June 2013, 14:29 GMT
Critical?!
Comment by Pavlos Touboulidis (pav) - Wednesday, 05 June 2013, 08:10 GMT
Being able to debug is a major part of MonoDevelop's usefulness so I thought "Critical" is appropriate.

Please change it to what you think is best and let's focus on the problem.
Comment by Jelle van der Waa (jelly) - Wednesday, 05 June 2013, 09:26 GMT
Do you have extra/monodevelop-debugger-gdb 4.0-1 installed?
Comment by Pavlos Touboulidis (pav) - Wednesday, 05 June 2013, 09:41 GMT
I have tried both with and without it with the same result. I think the problem is related to mono's own "soft" debugger. However, even if I set GDB to be at the top of the list of preferred debuggers, I still get the same error.

Can anyone reproduce this?
Comment by Pavlos Touboulidis (pav) - Friday, 14 June 2013, 05:49 GMT
It looks like this happens on other distributions too so I've reported upstream: https://bugzilla.xamarin.com/show_bug.cgi?id=12684
Comment by Jelle van der Waa (jelly) - Friday, 14 June 2013, 10:06 GMT
Thanks for reporting it to upstream!
Comment by Pavlos Touboulidis (pav) - Friday, 14 June 2013, 19:35 GMT
Workaround: untick the "Run on external console" checkbox in the project run settings.
Comment by Gianfrancesco P Scardua (Ritotsume) - Thursday, 26 February 2015, 16:37 GMT
If the error occurs in gnome do the following:

1) Install the xterm.
2) open a terminal and type:
$ Unset GNOME_DESKTOP_SESSION_ID
$ monodevelop

Worked with me.

Someone can make it permanent.
Comment by Isenmann Daniel (ise) - Tuesday, 07 July 2015, 07:23 GMT
Just for information: At the moment I have too little time for Arch, I will do my best to find a solution in the next upcoming weeks.
Comment by Isenmann Daniel (ise) - Tuesday, 21 July 2015, 19:11 GMT
Asked upstream for status

Loading...