Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35580 - [inteutils] Don't allow non-alphanumeric characters in hostname (inetutils)

Attached to Project: Arch Linux
Opened by Dominik Richter (arlimus) - Friday, 31 May 2013, 23:21 GMT
Last edited by Eric Belanger (Snowman) - Sunday, 09 June 2013, 17:42 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Eric Belanger (Snowman)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Setting hostname to contain non-alphanumeric characters can lead to problems. Example: Setup routines in python3 regularly call os.uname(), which crashes on non-ascii characters.

Example steps to reproduce:

sudo hostname hât
python -c "import os; os.uname()"

or trying to build python packages, typically in AUR, eg: https://aur.archlinux.org/packages/quickswitch-i3

sudo hostname hât
makepkg
...
UnicodeDecodeError: 'ascii' codec can't decode byte 0xe2 in position 0: ordinal not in range(128)
...
==> ERROR: Makepkg was unable to build quickswitch-i3.

This does not seem to be a python problem, since these characters are not allowed according to RFCs 952, 1123, 1178 (see [1-4])

I hope this bug has found a home ;)

Info:

inetutils 1.9.1-5
Linux hât 3.9.4-1-ARCH #1 SMP PREEMPT Sat May 25 16:14:55 CEST 2013 x86_64 GNU/Linux
Python 3.3.2-1

Additional info:
[1] http://tools.ietf.org/html/rfc952
[2] http://tools.ietf.org/html/rfc1123
[3] http://tools.ietf.org/html/rfc1178
[4] Bug discussion on python bugs: http://bugs.python.org/issue18109
This task depends upon

Closed by  Eric Belanger (Snowman)
Sunday, 09 June 2013, 17:42 GMT
Reason for closing:  Upstream
Additional comments about closing:  Report upstream or use another hostname.
Comment by Dominik Richter (arlimus) - Tuesday, 04 June 2013, 05:21 GMT
Python has been fixed upstream to support non-ascii characters in hostnames now [1]. So it won't break python builds from AUR anymore.
Nevertheless, this will likely come up again, but at least it doesn't break anything at the moment.

[1] http://bugs.python.org/issue18109

Loading...