Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35479 - [terminus-font] Changes to .install file result in fonts not being found

Attached to Project: Community Packages
Opened by MR (markram) - Sunday, 26 May 2013, 07:52 GMT
Last edited by Alexander F. Rødseth (xyproto) - Tuesday, 03 December 2013, 15:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
The new terminus-font.install file runs 'mkfontscale usr/share/fonts/TTF' and 'mkfontdir usr/share/fonts/TTF' on the wrong directory which means that some programs can't font the Terminus fonts.

Additional info:
package version: terminus-font 4.38-2

Steps to reproduce:
-Install rxvt-unicode and adjust settings in ~/.Xresources to use the Terminus fonts
-Run 'xset +fp /usr/share/fonts/local && xset fp rehash' after X starts
-urxvt will not run because 'fonts.dir' is missing in the '/usr/share/fonts/local' directory
-Manually run 'mkfontscale usr/share/fonts/local' and 'mkfontdir usr/share/fonts/local' to get urxvt to run
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Tuesday, 03 December 2013, 15:28 GMT
Reason for closing:  Fixed
Comment by MR (markram) - Sunday, 26 May 2013, 08:23 GMT
Pretend the summary is prefixed with "[terminus-font] 4.38-2". I missed that part.
Comment by Cédric (Tristelune) - Monday, 03 June 2013, 09:41 GMT
I have the same problem. The problem is fixed if I run mkfontscale and mkfontdir manually.
Comment by bill (freestyler7) - Wednesday, 31 July 2013, 23:24 GMT
Still not fixed. This a popular font and i'm sure it have troubled many people.
Comment by clonejo (clonejo) - Thursday, 01 August 2013, 10:55 GMT
Proposed fix attached (untested).
Comment by P.H. (Vain) - Saturday, 16 November 2013, 20:18 GMT
Any updates on this? Not that I install the package on a daily basis :-) but it's easy to fix, see clonejo's attachment.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 03 December 2013, 15:19 GMT
Adopted the bug and the package. Fixing the package right now.
Comment by Alexander F. Rødseth (xyproto) - Tuesday, 03 December 2013, 15:27 GMT
Updated and pushed the package. It should appear in [community] shortly.

Loading...