Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35461 - [cifs-utils] Upgrade breaks krb5 authentication

Attached to Project: Arch Linux
Opened by Brandon (hashstat) - Friday, 24 May 2013, 18:44 GMT
Last edited by Tobias Powalowski (tpowa) - Friday, 20 June 2014, 18:36 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Tobias Powalowski (tpowa)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No



A recent system upgrade broke CIFS mounting using kerberos. Before the upgrade, the following mount command worked flawlessly:

$ sudo mount -t cifs -o sec=krb5,cruid=1000 //server/share/folder /mnt

After the upgrade, the above command produces the following error:

mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

No relevent entries were appended to the system log.

Downgrading to the previous versions of cifs-utils and keyutils corrects the problem.

Additional info:
* package version(s)
cifs-utils: 6.0-2 (upgraded from 6.0-1)
keyutils: 1.5.5-4 (upgraded from 1.5.5-3

Steps to reproduce:

1. Initialize the kerberos credential cache using

$ kinit principal

2. Mount a Windows share that is accessible using kerberos authentication

$ sudo mount -t cifs -o sec=krb5,cruid=1000 //server/share/folder /mnt
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 20 June 2014, 18:36 GMT
Reason for closing:  Fixed
Comment by Tobias Powalowski (tpowa) - Saturday, 25 May 2013, 09:09 GMT
Could it be that in keyutils paths of binaries changed?
Comment by Tobias Powalowski (tpowa) - Tuesday, 28 May 2013, 13:58 GMT
Please try latest keyutils with updated request-key.conf file.
Comment by Brandon (hashstat) - Wednesday, 29 May 2013, 18:31 GMT
I tried keyutils 1.5.5-5 from the testing repository and continue to see the same error:

$ sudo mount -v -t cifs -o sec=krb5,cruid=1000 //my.server/share /mnt
[sudo] password for brandon:
mount.cifs kernel mount options: ip=XXX.XXX.249.47,unc=\\my.server\share,sec=krb5,cruid=1000,user=root,pass=********
mount error(2): No such file or directory
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Mounting with "-o username=USERNAME,domain=DOMAIN" continues to work after prompting for a password.
Comment by Tobias Powalowski (tpowa) - Monday, 16 June 2014, 07:58 GMT
Should work with latest cifs-utils.
Comment by Brandon (hashstat) - Friday, 20 June 2014, 18:30 GMT
I verified that this does in fact work now. Thank you.