Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35445 - [udisks][gvfs] 3.8.8 - 3.9.x USB enclosure drive doesn't work after system update

Attached to Project: Arch Linux
Opened by Antek Aduszkiewicz (senjin) - Thursday, 23 May 2013, 19:42 GMT
Last edited by Jan de Groot (JGC) - Sunday, 16 February 2014, 10:13 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tom Gundersen (tomegun)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 5
Private No

Details

Description:
My portable USB drive (it's a 2.5" disk in USB enclosure) stopped to work after system update this month. It can't be mounted, an icon doesn't appear on the desktop.

Other USB devices, even USB drives still work. The problem is not hardware related, as:
- the problematic drive works on another computer
- after downgrading the whole system to version from April 1, 2013 using ARM the drive works normally
- the same problem appeared on a completely different machine after system upgrade, and also I cured it by downgrading the system.

I provide logs and more detailed information in the following thread:
https://bbs.archlinux.org/viewtopic.php?pid=1272681#p1272681
This task depends upon

Closed by  Jan de Groot (JGC)
Sunday, 16 February 2014, 10:13 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed in udisks 2.1.2-1
Comment by Tobias Powalowski (tpowa) - Tuesday, 28 May 2013, 14:17 GMT
Please bisect and report upstream, I cannot help you.
Comment by Antek Aduszkiewicz (senjin) - Tuesday, 28 May 2013, 14:49 GMT
Ok, I will try...
Comment by arch user (archuser474747) - Thursday, 30 May 2013, 14:58 GMT
I've got a similar problem with an external drive going undetected when plugged into a USB3 port, but working just fine with a USB2 port. Found this kernel bug:

https://bugzilla.kernel.org/show_bug.cgi?id=57981

Is your USB drive USB3? Tried plugging it into a USB2 port?
Comment by Antek Aduszkiewicz (senjin) - Friday, 31 May 2013, 09:19 GMT
One of my computers has been bought in 2006, so it can't have USB3 ports :) Also my dmesg errors looked quite different from the ones included in the bug report you are quoting.

Hopefully on the weekend I will have some time to play with various update snapshots from ARM, and maybe I will manage to give more specific information on what is causing problems.
Comment by Rafal Michalski (PLum) - Thursday, 06 June 2013, 12:52 GMT
had the same problem - Just checket the same drive on systemrescuecd - and all working fine, can mount truecrypt partition without any issue,
who and what did with usb-storage support in latest kernels ?!?
Comment by Antek Aduszkiewicz (senjin) - Thursday, 06 June 2013, 22:41 GMT
Ok, I think I got it. Sorry that it took so long time, but testing was difficult, and I had little time to do it. I was upgrading and downgrading the whole system using ARM and I was really puzzled that sometimes things worked, or didn't work with the same versions of all packages... finally I realised that I can mount the USB disk with no problem as long as I don't start DE.

Uninstalling gvfs package removes the problem. This is of course not a solution, since gvfs is an important package, and I have to mount the USB disk manually with 'mount', but it works. This is the situation with the system updated today.

So it seems this is not problem with kernel.

It *might* be related to problems with udisks2, which I found mentioned here:
https://bugs.launchpad.net/ubuntu/+source/libatasmart/+bug/1161985
Comment by Antek Aduszkiewicz (senjin) - Saturday, 08 June 2013, 09:02 GMT
Yesterday upgrade of gvfs to 1.16.2-2 doesn't help.

Downgrading gvfs to 1.14.2-4 and udisks2 to 2.0.1-1 solves the problem.

Upgrading to gvfs 1.16.1-1 and udisks2 2.1.0-1 causes problems. It seems that these packages depend on each other's version, and they don't work well if I change version of only one of them, so I couldn't determine which one is causing bug. Anyway, my understanding is that gvfs is using udisks2, so I would blame udisks2.
Comment by Tobias Powalowski (tpowa) - Saturday, 08 June 2013, 09:43 GMT
You use not the official arch repo, but the ARM version?
Comment by Antek Aduszkiewicz (senjin) - Saturday, 08 June 2013, 09:54 GMT
The system is now updated with the official repos, except of the gvfs and udisks2 packages I needed to downgrade to make my drive working.
Comment by Tobias Powalowski (tpowa) - Saturday, 08 June 2013, 10:04 GMT
Is it an ARM or x86_64/i686?
Comment by Antek Aduszkiewicz (senjin) - Saturday, 08 June 2013, 10:10 GMT
Official x86_64 repository, not ARM. The 2 packages I used to downgrade are probably from ARM.

But the problem appeared also on another machine, where I have i686 installed. However on that machine I did not do any testing, except of dowgrading to 2013 April 1 from ARM to make things work.
Comment by Łukasz Gromanowski (lgromanowski) - Saturday, 08 June 2013, 17:36 GMT
It's a problem with udisks2 - I have same problem with HDD connected via USB, and I didn't had gvfs package installed. Downgrading udisks2 to 2.0.1-1 solved the issue.
Comment by Antek Aduszkiewicz (senjin) - Monday, 10 June 2013, 12:11 GMT
OK, so what is the next step? Should I send a report here http://www.freedesktop.org/wiki/Software/udisks/ ?
I will try to do it in the evening.
I couldn't find any similar bug in their bugtracker.
Comment by Tom Eales (wingsuit) - Saturday, 15 June 2013, 09:29 GMT
My 3.9.4-1-ARCH x86_64 running XFWM and XFCE is having the same problem. No drive will be recognised by the USB 3.0 port.
Comment by Antek Aduszkiewicz (senjin) - Saturday, 15 June 2013, 10:58 GMT
I submited the bug upstream.

https://bugs.freedesktop.org/show_bug.cgi?id=65785

I sent several logfiles – please compare them with what you get.

In particular, Tom, I'm not sure if you have the same problem. For me the problems appear on USB2 ports. Maybe you should check the link from archuser474747.
Comment by Gerardo Exequiel Pozzi (djgera) - Tuesday, 11 February 2014, 20:15 GMT
status? Upstream says: RESOLVED NOTOURBUG.
Comment by Jan de Groot (JGC) - Friday, 14 February 2014, 12:25 GMT

Loading...