Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#35429 - [pacman] on install shows /var/cache/pacman/pkg too full on ramfs

Attached to Project: Pacman
Opened by Adam Faryna (sanczo) - Wednesday, 22 May 2013, 20:54 GMT
Last edited by Dave Reisner (falconindy) - Thursday, 23 May 2013, 11:45 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I mount /var/cache/pacman/pkg as a ramfs partition.
After update pacman to 4.1.1-1 I have a problem installing any packages because of not enough free disk space but I have about 7GB free memory.

Additional info:
pacman 4.1.1-1

sudo pacman -S libxml2
warning: libxml2-2.9.1-1 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...

Packages (1): libxml2-2.9.1-1

Total Download Size: 1,52 MiB
Total Installed Size: 11,19 MiB
Net Upgrade Size: 0,00 MiB

:: Proceed with installation? [Y/n] Y
error: Partition /var/cache/pacman too full: 390 blocks needed, 0 blocks free
error: failed to commit transaction (not enough free disk space)
Errors occurred, no packages were upgraded.


Steps to reproduce:
Mount /var/cache/pacman/pkg as ramfs and run:
pacman -S <any-package>
This task depends upon

Closed by  Dave Reisner (falconindy)
Thursday, 23 May 2013, 11:45 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#34707 
Comment by Jan de Groot (JGC) - Wednesday, 22 May 2013, 22:09 GMT
Ramfs doesn't do size calculations. It also does not show up in df output.
Comment by Adam Faryna (sanczo) - Saturday, 25 May 2013, 07:03 GMT
@Jan thx, switched to tmpfs now everything is working.

Loading...