Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35420 - [rxvt-unicode] perl 5.18.0-1 and urxvt 9.18-4 break tabbed extension for urxvt

Attached to Project: Community Packages
Opened by Karol Błażewicz (karol) - Wednesday, 22 May 2013, 13:16 GMT
Last edited by Sébastien Luttringer (seblu) - Sunday, 26 May 2013, 02:12 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Sébastien Luttringer (seblu)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


$ urxvtc -pe tabbed
urxvt: perl hook 0 evaluation error: /usr/lib/urxvt/perl/tabbed: syntax error at /usr/lib/urxvt
syntax error at /usr/lib/urxvt/perl/tabbed line 426, near "}

Effect: urxvt opens a non-tabbed terminal window.
Expected effect: urxvt opens a tabbed terminal window.

Downgrading to perl 5.16.3-3 and rxvt-unicode 9.18-3 fixes the problem and restores correct behavior.
This task depends upon

Closed by  Sébastien Luttringer (seblu)
Sunday, 26 May 2013, 02:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  rxvt-unicode-9.18-5
Comment by Shawn Nock (nocko) - Thursday, 23 May 2013, 14:56 GMT
urxvt seg faults on my machine (x86_64), perl 5.18.0-1 and rxvt-unicode 9.18-3 if the loading of any perl extensions are attempted, even the defaults. Practically speaking, this package is broken completely after an upgrade to perl 5.18.

A work-around is to disable all perl extensions (which allow urxvt to start), but adding the following lines to .Xdefaults:

URxvt*perl-ext-common: ""
URxvt*perl-ext: ""

and running: urxvt -pe ""

Please upgrade the severity to High.
Comment by Shawn Nock (nocko) - Thursday, 23 May 2013, 14:59 GMT
Error message:

Perl API version v5.16.0 of urxvt does not match v5.18.0
urxvt: unable to initialize perl-interpreter, continuing without.
Comment by Karol Błażewicz (karol) - Thursday, 23 May 2013, 15:03 GMT
You should be running perl 5.18.0-1 and rxvt-unicode 9.18-4 or downgrade both packages, as rxvt-unicode 9.18-4 needs perl from testing

perl 5.18.0-1 and rxvt-unicode 9.18-3 won't work, [testing] is all or nothing.
Comment by Shawn Nock (nocko) - Thursday, 23 May 2013, 15:11 GMT
I forgot that I disabled community-testing a few weeks ago after a particularly bad spell. I re-enabled it and things are working normally. Sorry for the noise.
Comment by Sébastien Luttringer (seblu) - Thursday, 23 May 2013, 19:16 GMT
ok, others perl extensions works correctly.

Please report this upstream.
Comment by Vladimir (_v_l) - Friday, 24 May 2013, 04:32 GMT

sorry to open the bug again but on official web site (Am I right with address?) I didn't find where to report about bugs (only irc), so I post patch here and I'll ask about it inclusion on IRC.

The reason of the bug:
Comment by Sébastien Luttringer (seblu) - Friday, 24 May 2013, 11:18 GMT
Don't be sorry, the bug was not closed.

You coulld use the mailing list to send a patch or report issues :

It's a pretty obvious patch, but please send it upstream and I will include it.
Comment by Karol Błażewicz (karol) - Saturday, 25 May 2013, 22:37 GMT