Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35361 - [nvidia] Xinerama broken with kernel 3.9 and nvidia 319

Attached to Project: Arch Linux
Opened by Dennis (sqtux) - Sunday, 19 May 2013, 12:37 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Monday, 20 May 2013, 09:15 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Ionut Biru (wonder)
Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
All packages using the x11 library (e.g. slim, xterm, ...)
are segfaulting because of segfaults from libx11 after upgrading
to kernel 3.9 and the corresponding nvidia propretiary driver 319.

Disabling xinerama or using kernel 3.8 and nvidia 313 fixes this bug.

Example output:
xterm[1378]: segfault at 8 ip 00007fb1c0e09080 sp 00007fff3f994c08 error 4 in libX11.so.6.3.0[7fb1c0dd8000+133000]

Steps to reproduce:
Upgrade to newest kernel and nvidia driver, enable xinerama in xorg.conf.
This task depends upon

Closed by  BartÅ‚omiej Piotrowski (Barthalion)
Monday, 20 May 2013, 09:15 GMT
Reason for closing:  Upstream
Comment by Jelle van der Waa (jelly) - Monday, 20 May 2013, 09:08 GMT
I don't think we will be able to fix this bug, since it's probably generated by the closed source nvidia driver. So please report it to the nvidia devs.

Loading...