Community Packages

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35353 - [f2fs-tools] No UUID generated root partition

Attached to Project: Community Packages
Opened by Ray Clancy (lilsirecho) - Saturday, 18 May 2013, 14:57 GMT
Last edited by Tobias Powalowski (tpowa) - Thursday, 23 May 2013, 16:04 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Jelle van der Waa (jelly)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


Description:With linux-3.9.2-1 kernel to be installed using dual arch .iso for april, and generating a mdadm raid0 system, the f2fs-tools installed and f2fs modprobed, no UUID is assigned to the root device.

Additional info: Using Compact Flash 16GB 533x with sata adapter
* package version(s)
* config and/or log files etc.

Steps to reproduce:Use arch dual.iso, enter ip link and utilize dhcp or as I have to do, setup ip link for static ip and dns servers.

Use cfdisk to partition with freespace of 5mb, boot partition of 50mb and remaining space divided into two partitions (Used in raid0 array)
Create in mdadm /dev/mdxx a raid0 array using the pair of partitions above set up.

Modprobe f2fs. Install via pacman f2fs-tools.

mkfs.f2fs /dev/mdxx. This invokes f2fs-tools upon the partition but does not create UUID.

Searched internet for UUID problem and discovered it was common but not archlinux related solutions were encountered.

The installation of archlinux was then completed and grub-bios installed. The system does not then boot.

Examination of the resultant device install via another boot device while in chroot reveals that the entire f2fs system exists in the Compact Flash device. Fstab shows just *TYPE f2fs* for the root device.

Blkid lists the device as "type=f2fs" with no UUID.

Suspect that f2fs-tools lacks UUID interface setup.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Thursday, 23 May 2013, 16:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.1.0_130404
Comment by Ray Clancy (lilsirecho) - Sunday, 19 May 2013, 21:09 GMT
To allay any feling that this procedure is faulty, I have 14 such raid0 grub2 bootable Compact Flash archlinux operating systems. All of them are either ext3 or ext4 filesystems and boot with grub2.

The fstab lists the /dev/mdxx with a uuid and blkid also shows UUID.

These raid0 systems have been operating well for several months.

Only f2fs is not responding as expected especially not providing a UUID with f2fs-tools.. If such were provided, it is likely that the system with raid0 would boot from grub2.

The f2fs array /dev/mdxx can be mounted when archlinux is booted in another raid0 boot device so the base and base-devel elements are installed.

I assume with a proper UUID that grub2 will boot f2fs /dev/mdxx.
Comment by Ray Clancy (lilsirecho) - Tuesday, 21 May 2013, 15:13 GMT
Further info herein shows fstab:

# /etc/fstab: static file system information
# <file system> <dir> <type> <options> <dump> <pass>
# /dev/md24
/dev/md24 / f2fs rw,relatime,background_gc_on,user_xattr,acl,active_logs=6 0 1

Comment by Ray Clancy (lilsirecho) - Tuesday, 21 May 2013, 18:00 GMT
This entry is from a booted raid0 ext4 grub2 archlinux system showing the /root uuid:

# /etc/fstab: static file system information
# <file system> <dir> <type> <options> <dump> <pass>
# /dev/md21
UUID=68af41a2-2fd9-41e9-952d-d89f7a1fdbc3 / ext4 rw,relatime,stripe=256,data=ordered 0 2

You can note the /dev/md21 is commented out and the UUID is listed for the root partition. The use of pass 2 is not what I expected but this arrangement performs in ext4 mode.

This example illustrates that ext4 fs provides a uuid with install via .iso on mdadm /root partition.
Comment by Jelle van der Waa (jelly) - Thursday, 23 May 2013, 11:12 GMT
Nevermind bug reports, the git version has uuid generation support, so hopefully this will land soon into a new release since I'm not eager to backport changes.
Comment by Tobias Powalowski (tpowa) - Thursday, 23 May 2013, 12:14 GMT
How about packaging latest git?