Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35325 - [minidlna] can't start when booting pc

Attached to Project: Community Packages
Opened by Andrew (Belitsky.A) - Thursday, 16 May 2013, 15:02 GMT
Last edited by Sergej Pupykin (sergej) - Saturday, 16 November 2013, 18:46 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
when arch is booting minidlna can't start with error:

May 14 19:08:59 dots systemd[1]: Starting minidlna server...
May 14 19:09:02 dots minidlnad[243]: [2013/05/14 19:09:02] minidlna.c:528: No MAC address found. Falling back to generic UUID.
May 14 19:09:02 dots minidlnad[243]: [2013/05/14 19:09:02] minidlna.c:927: fatal: No IP address automatically detected!
May 14 19:09:02 dots systemd[1]: minidlna.service: control process exited, code=exited status=255
May 14 19:09:02 dots systemd[1]: Failed to start minidlna server.
May 14 19:09:02 dots systemd[1]: Unit minidlna.service entered failed state.

But I can start it manually after boot and minidlna works whitout this problem.


Additional info:
* package version(s): 1.1.0-1


Steps to reproduce:
1. # systemd enable minidlna
2. reboot pc
This task depends upon

Closed by  Sergej Pupykin (sergej)
Saturday, 16 November 2013, 18:46 GMT
Reason for closing:  Not a bug
Additional comments about closing:  or upstream
Comment by Sergej Pupykin (sergej) - Friday, 17 May 2013, 10:20 GMT
What if you add

Requires=network.target

into .service [Unit] section?
Comment by Andrew (Belitsky.A) - Friday, 17 May 2013, 10:44 GMT
it did not help, same error
Comment by Andrew (Belitsky.A) - Friday, 17 May 2013, 11:30 GMT
forgot to say, I'm using NetworkManager
Comment by Morris (kabum) - Monday, 27 May 2013, 08:11 GMT
Same here. I can also provide some logs, if anybody point me to them.

Andrew: Where are your logs from?
Comment by Andrew (Belitsky.A) - Monday, 27 May 2013, 08:40 GMT
Morris:
You need to run this from root:
# journalctl -b -u minidlna
Comment by Morris (kabum) - Monday, 27 May 2013, 08:42 GMT
Mai 27 10:06:56 wigrid systemd[1]: Starting minidlna server...
Mai 27 10:06:56 wigrid minidlnad[420]: [2013/05/27 10:06:56] minidlna.c:528: No MAC address found. Falling back to generic UUID.
Mai 27 10:06:57 wigrid minidlnad[420]: [2013/05/27 10:06:57] minidlna.c:927: fatal: No IP address automatically detected!
Mai 27 10:06:57 wigrid systemd[1]: minidlna.service: control process exited, code=exited status=255
Mai 27 10:06:57 wigrid systemd[1]: Failed to start minidlna server.
Mai 27 10:06:57 wigrid systemd[1]: Unit minidlna.service entered failed state

I use NetworkManager too. So maybe the problem is there
Comment by Andrew (Belitsky.A) - Monday, 27 May 2013, 14:11 GMT Comment by Art (kabera) - Monday, 11 November 2013, 11:32 GMT
  • Field changed: Percent Complete (100% → 0%)
I do not use networkmanager but have the same problem.
journalctl -b -u minidlna
-- Logs begin at Thu 1970-01-01 01:00:04 CET, end at Thu 2013-09-19 07:27:18 CES
Jan 01 01:00:22 117pi systemd[1]: Starting minidlna server...
Jan 01 01:00:25 117pi systemd[1]: minidlna.service: control process exited, code
Jan 01 01:00:25 117pi systemd[1]: Failed to start minidlna server.
Jan 01 01:00:25 117pi systemd[1]: Unit minidlna.service entered failed state.
Jan 01 01:00:39 117pi systemd[1]: Starting minidlna server...
Jan 01 01:00:40 117pi minidlnad[300]: [1970/01/01 01:00:40] minidlna.c:528: No M
Jan 01 01:00:40 117pi minidlnad[300]: [1970/01/01 01:00:40] getifaddr.c:114: err
Jan 01 01:00:40 117pi systemd[1]: minidlna.service: control process exited, code
Jan 01 01:00:40 117pi systemd[1]: Failed to start minidlna server.
Jan 01 01:00:40 117pi systemd[1]: Unit minidlna.service entered failed state.
Comment by Sergej Pupykin (sergej) - Monday, 11 November 2013, 12:04 GMT
I think you should modify you .service file adding something like
Wants=sys-subsystem-net-devices-eth0.device
or something else, so minidlna will start only after network interface is up.

Not sure if there is universal way to wait network.
Comment by Sergej Pupykin (sergej) - Saturday, 16 November 2013, 18:45 GMT
http://www.freedesktop.org/wiki/Software/systemd/NetworkTarget/

> Alternatively, you can write your own service file wrapping any other program or script you like and simply
order it before network.target (with Before=). Your service also needs to pull in network.target (with Wants=), to indicate that it implements this target.

Loading...