Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35321 - [libgdiplus] Build failure from ABS: undefined reference to `QuantizeBuffer'

Attached to Project: Arch Linux
Opened by Chris Oelmueller (ChrisOelmueller) - Thursday, 16 May 2013, 10:17 GMT
Last edited by Gerardo Exequiel Pozzi (djgera) - Thursday, 16 May 2013, 11:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Attempting to build libgdiplus yields, amongst others:
../src/.libs/libgdiplus.so: undefined reference to `QuantizeBuffer'

Whole build log:
http://bpaste.net/show/HyfEG5vauuxeSN3dOmBa/

To "fix" this, i passed the flag `--without-libgif` to ./configure. This disables gif support however which is not desired.
Unsetting LDFLAGS before ./configure did not fix the issue for me.

Additional info:
libgdiplus 2.10-4
libpng 1.6.2-3
stock cairo 1.12.14-4
This task depends upon

Closed by  Gerardo Exequiel Pozzi (djgera)
Thursday, 16 May 2013, 11:21 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Rep orting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

Loading...