Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35310 - [gnome] 3.8.2 and Catalyst black screen at boot

Attached to Project: Arch Linux
Opened by Britt Yazel (brittyazel) - Wednesday, 15 May 2013, 18:31 GMT
Last edited by Jan Steffens (heftig) - Tuesday, 04 June 2013, 03:20 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 14
Private No

Details

Description:
With yesterdays updates to the Gnome desktop to 3.8.2 many people, including myself, are being greeted at first boot with a solid black screen due to GDM no loading correctly. More details on this issue can be read here: https://bbs.archlinux.org/viewtopic.php?id=163331

To correct this issue a downgrade must be made to mutter and gnome-shell to their 3.8.1 previously working versions.

Also, myself and the other members of that forum thread seem to be having the issue pertaining to the Catalyst drivers, though I do not know if that is a coorelation or not.

This task depends upon

Closed by  Jan Steffens (heftig)
Tuesday, 04 June 2013, 03:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  Problem disappeared after rebuilding with -Wl,--as-needed.
Comment by Günter Loch (gnloch) - Wednesday, 15 May 2013, 19:36 GMT
Same problem here. My .xsession-errors is attached.
Comment by Jan Steffens (heftig) - Wednesday, 15 May 2013, 19:48 GMT
Both mutter and gnome-shell need a downgrade? Or only one?
Comment by Britt Yazel (brittyazel) - Wednesday, 15 May 2013, 19:55 GMT
I downgraded both, though the forum thread reported that only mutter should be necessary. I can test once I get back to my computer
Comment by Wojtek Bogócki (SnowyMan95) - Wednesday, 15 May 2013, 20:01 GMT
I've only gnome-shell and totem downgraded and everything works. I don't think downgrading mutter is necessary.
Comment by Jan Steffens (heftig) - Wednesday, 15 May 2013, 20:03 GMT
Could you please try rebuilding gnome-shell 3.8.1 and 3.8.2 locally, to see if it works?
Comment by Wojtek Bogócki (SnowyMan95) - Wednesday, 15 May 2013, 20:05 GMT
I could, but only if you tell me how to do that ^^
Comment by Jarkko Immonen (eyemonen) - Wednesday, 15 May 2013, 20:36 GMT
Yes, downgrading gnome-shell is enough, no need to downgrade mutter.

I built gnome-shell 3.8.2 locally but it didn't help.
Comment by Mirandir (mirandir) - Wednesday, 15 May 2013, 20:53 GMT
I have the same problem. Downgrading mutter is not necessary, only gnome-shell.
Comment by egor (aegor386) - Wednesday, 15 May 2013, 21:37 GMT
same problem with gnome-shell-3.8.2-1(2) and catalyst-total-hd234k 13.1-7 from AUR:
Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined

% uname -srm
Linux 3.9.2-1-ARCH x86_64
Comment by Günter Loch (gnloch) - Wednesday, 15 May 2013, 22:09 GMT
I downgraded gnome-shell (3.8.2-2 -> 3.8.1-1) and totem (3.8.2-1 -> 3.8.0-1) from pacman's cache, and it fixed the problem.
Comment by Britt Yazel (brittyazel) - Wednesday, 15 May 2013, 23:24 GMT
Could it be do to the fact gdm is still on 3.8.1 though gnome-shell wants to update to 3.8.2? Maybe the version issue is causing incompatibility between the two
Comment by Britt Yazel (brittyazel) - Thursday, 16 May 2013, 00:18 GMT
I can confirm that only the gnome-shell package is causing the error. I have updated the mutter package without issue
Comment by Britt Yazel (brittyazel) - Thursday, 16 May 2013, 00:20 GMT
I can also confirm the issue with totem as well, and downgrading to the totem-3.8.0-1 package fixed it for me as well
Comment by egor (aegor386) - Thursday, 16 May 2013, 01:42 GMT
> Could it be do to the fact gdm is still on 3.8.1 though gnome-shell wants to update to 3.8.2? Maybe the version issue is causing incompatibility between the two

Gnome doesn't start with startx too, this is not gdm trouble
Comment by Britt Yazel (brittyazel) - Thursday, 16 May 2013, 01:49 GMT
Well from my understanding gdm was dependent on gnome-shell for drawing the login screen.
Comment by Mirandir (mirandir) - Thursday, 16 May 2013, 05:18 GMT
Interesting fact : if I rebuild gnome-shell 3.8.1 myself, I have the same problem of black screen, with the same error.

So :
gnome-shell-3.8.2 : black screen
gnome-shell-3.8.1 builded by myself : black screen
old gnome-shell-3.8.1 of extra : works

Maybe gnome-shell 3.8.2 is not directly guilty.
Comment by Günter Loch (gnloch) - Thursday, 16 May 2013, 10:01 GMT
@Mirandir. Same for me.
Comment by Jan Steffens (heftig) - Thursday, 16 May 2013, 13:24 GMT
Does it work if you compile with a reverted glib2?
Comment by Mirandir (mirandir) - Thursday, 16 May 2013, 16:17 GMT
@Jan Steffens : no. I have compiled gnome-shell with glib2-2.36.1-3 and glib2-2.36.1-1 without success, the black screen and the errors remain.
Comment by Jan Steffens (heftig) - Thursday, 16 May 2013, 19:32 GMT
Would be great if you could find out what the cause is. I can't reproduce this myself.
Comment by Adoa Coturnix (adoa) - Thursday, 16 May 2013, 20:29 GMT
@Jan Steffens: As far as I can see, only catalyst users are affected. Is there anyone with this problem *not* using catalyst?
Comment by Francescodario Cuzzocrea (Alastor89) - Thursday, 16 May 2013, 20:44 GMT
I also have this problem only with catalyst (also after a clean installation of Arch). No problems with open source drivers.
Comment by Vincent Storme (5torme) - Thursday, 16 May 2013, 22:32 GMT
This is also affecting me. Catalyst + Gnome 3.8.2. Reverting to 3.8.1 doesn't fix it. Using linux 3.9.2
Comment by Britt Yazel (brittyazel) - Thursday, 16 May 2013, 22:41 GMT
@5torme rolling back the gnome-shell package didn't fix it? That is what seemed to work for all of us
Comment by Vincent Storme (5torme) - Thursday, 16 May 2013, 23:09 GMT
@brittyazel downgraded gnome-shell, gnome-desktop, mutter, and totem. No luck :(
Comment by Vincent Storme (5torme) - Friday, 17 May 2013, 01:21 GMT
UPDATE: switched to open drivers, everything works. Catalyst == problems with gnome
Comment by Britt Yazel (brittyazel) - Friday, 17 May 2013, 02:33 GMT
is there any way to assign Vi0L0 to this issue as well? This seems to be a catalyst issue, and something odd has changed from gnome 3.8.1 to 3.8.2 that breaks clutter's ability to recognize the catalyst openGL version.
Comment by Jan de Groot (JGC) - Friday, 17 May 2013, 09:06 GMT
My guess is cogl is the cause for this. Rebuilding anything against cogl 1.14.0-2 causes that application to fail with catalyst. Can someone try removing the wayland stuff that was added to cogl 1.14.0-2 and rebuild gnome-shell + mutter against that?
Comment by Jarkko Immonen (eyemonen) - Friday, 17 May 2013, 11:42 GMT
Compiled Cogl without wayland and gles support and Clutter without wayland and egl-backend. After that rebuilding gnome-shell resulted in fully working system. Removing only wayland stuff didn't work for me.
Comment by Jan de Groot (JGC) - Friday, 17 May 2013, 11:53 GMT
Can you attach the output of glxinfo when running with catalyst?
Comment by Jarkko Immonen (eyemonen) - Friday, 17 May 2013, 12:24 GMT
@Jan: here you are.

Haven't had time enough to use the system much but it seems to work.
Comment by Mirandir (mirandir) - Friday, 17 May 2013, 14:37 GMT
I can confirm, it's worked.
Comment by Jan de Groot (JGC) - Friday, 17 May 2013, 14:41 GMT
Can someone try if only removing --enable-egl-backend from clutter fixes this problem?
Comment by Mirandir (mirandir) - Friday, 17 May 2013, 15:48 GMT
I have tried -- it doesn't work (for me, at least).
I have to recompile cogl with --enable-cogl-gles2=no, clutter with --enable-wayland-{backend,compositor}=no and without --enable-egl-backend.
Then, I recompile gnome-shell 3.8.2 and it works (it's similar for totem 3.8.2).
Comment by Vi0L0 (Vi0L0) - Friday, 17 May 2013, 16:10 GMT
I can confirm Mirandir's words except that I had to compile cogl (also) without wayland.

Should I add all those packages (including totem) into catalyst repositories until proper fix will arrive?
Comment by Francesco Di Nardo (angelsoul) - Friday, 17 May 2013, 16:41 GMT
Same problem here.

Sys:
Linux 3.9.2-1-ARCH x86_64
Catalyst-13.1-6
Xorg 1.12

It's work if downgrade gnome-shell (=3.8.1-1) and totem (=3.8.0-1)
Comment by Britt Yazel (brittyazel) - Friday, 17 May 2013, 22:20 GMT
Why are these issue just now causing issues with Catalyst? Did the gnome developers do something drastically different with this 3.8.2 version with how it is needing to be compiled?
Comment by Vincent Storme (5torme) - Saturday, 18 May 2013, 17:27 GMT
@Vi0L0's temp gnome-catalyst repo worked for me, can use catalyst + gnome together:

[gnome-catalyst]
Server = http://catalyst.wirephire.com/repo/gnome-catalyst/$arch
Comment by Francesco Di Nardo (angelsoul) - Saturday, 18 May 2013, 17:46 GMT
@Vincent Storme (5torme)
Is this repo for legacy graphic-card also (HD 4xxx)?
Comment by Vincent Storme (5torme) - Saturday, 18 May 2013, 20:39 GMT
@Francesco Di Nardo (angelsoul)
The repo patches gnome so it will work with catalyst. I'd assume it would work with legacy cards, but you may want to confirm with @Vi0L0 first.
Comment by Vi0L0 (Vi0L0) - Sunday, 19 May 2013, 13:59 GMT
Yes, temp repo should to work on hd234k without problems.
Just be sure to patch xorg-server 1.12 against GNOME 3.8.x or simply use packages from xorg112 repo
Comment by Richard Bywater (r2b2) - Monday, 20 May 2013, 08:14 GMT
Also downgraded to gnome-shell 3.8.1 and that seems to have fixed the issue. Attempted to use gnome-catalyst repo but the four packages seemed to give PGP errors even though I appear to have the keys loaded correctly.
Comment by Adoa Coturnix (adoa) - Monday, 20 May 2013, 09:17 GMT
@r2b2: you are not the only one with pgp errors in the gnome-catalyst repo, see https://bbs.archlinux.org/viewtopic.php?pid=1275156#p1275156
Comment by Cesar Ramirez (cesarramsan) - Wednesday, 22 May 2013, 18:46 GMT
I do not have gnome-shell, I am running i3 as my WM and I am using the Catalyst drivers.

When I run some applications I get seg-faults, an example of the error logs from totem is:

(totem:8316): GLib-CRITICAL **: g_strsplit: assertion `string != NULL' failed
(totem:8316): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined
(totem:8316): Totem-WARNING **: gtk-clutter failed to initialise, expect problems from here on.
(totem:8316): GLib-CRITICAL **: g_strsplit: assertion `string != NULL' failed
(totem:8316): Clutter-CRITICAL **: Unable to initialize Clutter: The OpenGL version could not be determined
Segmentation fault (core dumped)

I am using catalyst from:
[xorg113]
Server = http://catalyst.wirephire.com/repo/xorg113/$arch
Comment by Vi0L0 (Vi0L0) - Wednesday, 22 May 2013, 20:25 GMT
Look like you haven't installed packages from:

[gnome-catalyst]
Server = http://catalyst.wirephire.com/repo/gnome-catalyst/$arch
Comment by Loïc BLOT (Nerzhul) - Friday, 24 May 2013, 16:17 GMT
Confirmed, you must keep gnome-shell-3.8.1-1 (only) to get catalyst work
Comment by Cesar Ramirez (cesarramsan) - Sunday, 26 May 2013, 06:25 GMT
@Vi0L0 I installed the repo and now everything seems to be working fine.

@Nerzhul I didn't have gnome-shell installed and I still had problems. There is definitely a bigger problem, I think it is more related to gtk and catalyst.
Comment by Britt Yazel (brittyazel) - Sunday, 26 May 2013, 06:53 GMT
@cesarramsan to my knowledge, gdm will not work without gnome-shell installed, as it uses gnome-shell to draw the login screen. Perhaps the problems that you had without gnome-shell installed were attributed to that instead.
Comment by Cesar Ramirez (cesarramsan) - Sunday, 26 May 2013, 07:04 GMT
@brittyazel I am not using gdm, I am just using i3 as my wm and xinit to start it. But the same error that is affecting gdm for you is also affecting other applications such as totem and meld, all of which are using gtk. Applying the fixes from @Vi0l0 seem to fix it for me.
Comment by Britt Yazel (brittyazel) - Sunday, 02 June 2013, 19:21 GMT
I have reported this bug upstream at:
https://bugzilla.gnome.org/show_bug.cgi?id=701445
Any comments that you could make there to get this issue resolved would be appreciated
Comment by Jan Steffens (heftig) - Sunday, 02 June 2013, 19:56 GMT
@Vi0l0 I added overlinking fixes to a few packages, including gnome-shell and totem. See if that means it's now enough to strip wayland/EGL support from cogl and clutter (i.e. no rebuilding gnome-shell).
Comment by Vi0L0 (Vi0L0) - Sunday, 02 June 2013, 20:41 GMT
@heftig: my system is now running only on your packages and everything seems to be fine, thanks for this update!
Can somebody confirm this? If so I will take down the temp repo :)
Comment by Vi0L0 (Vi0L0) - Sunday, 02 June 2013, 20:43 GMT
Not to mention that we could confirm that this bug report could be closed ;) ...
Comment by Loïc BLOT (Nerzhul) - Sunday, 02 June 2013, 20:43 GMT
I can confirm it works fine but since recent testing/filesystem update gnome-shell and GDM are slow to start but works perfect once launched... strange
Comment by egor (aegor386) - Sunday, 02 June 2013, 20:45 GMT
With the latest update of the gnome-shell (3.8.2-4 from Jan Steffens) the problem was solved for me (catalyst hd234k)
Comment by Jan Steffens (heftig) - Sunday, 02 June 2013, 20:54 GMT
@Vi0L0:

Any difference in "ldd /usr/bin/gnome-shell" between the problematic and the fixed official packages?

Temporarily turn off ASLR (/proc/sys/kernel/randomize_va_space) to get reproducible output that can be diffed.
Comment by Britt Yazel (brittyazel) - Sunday, 02 June 2013, 20:57 GMT
I can confirm that after removing the catalyst-gnome ppa everything works fine. Good work jan :-)
Comment by Mirandir (mirandir) - Monday, 03 June 2013, 04:53 GMT
Yes, it works for me, too.
Comment by Francesco Di Nardo (angelsoul) - Monday, 03 June 2013, 09:21 GMT
I removed gnome-catalyst and upgraded (really downgraded) the packages from "extra": cogl, clutter, totem, gnome-shell.
Now all works fine. Well done! thanks to Jan Steffens and Vi0L0.
Comment by Vi0L0 (Vi0L0) - Monday, 03 June 2013, 17:39 GMT
@heftig:
after disabling aslr it's still hard to read diffs output (see attachment)
   ldd.diff (15.6 KiB)

Loading...