Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35280 - [cmake] does not detect ImageMagick any more

Attached to Project: Arch Linux
Opened by Rudolf Polzer (rpolzer) - Tuesday, 14 May 2013, 18:19 GMT
Last edited by Andrea Scarpino (BaSh) - Monday, 03 June 2013, 11:19 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


See this upstream bug: ttp://;a=commitdiff;h=5fe98556
Long story short: ImageMagick renamed some library names, cmake no longer detects ImageMagick.

Additional info:
* cmake
* Gentoo patched the issue like this:

Steps to reproduce:
in any cmake-using project, run "cmake .". Observe:

converseen-0.6.2$ cmake .
-- Could NOT find ImageMagick (missing: ImageMagick_Magick++_LIBRARY) (found version "6.8.4-10")
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Monday, 03 June 2013, 11:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  cmake 2.8.11-2
Comment by Rudolf Polzer (rpolzer) - Tuesday, 14 May 2013, 18:20 GMT
Sorry for screwing up the link. It is:
Comment by Eric Belanger (Snowman) - Tuesday, 14 May 2013, 22:45 GMT
You can specify the imagemagick library. See PKGBUILD in ABS:
cmake ../${pkgname}-${pkgver} \
-DImageMagick_Magick++_INCLUDE_DIR:PATH=/usr/include/ImageMagick-6 \
-DImageMagick_Magick++_LIBRARY:FILEPATH=/usr/lib/ \
-DImageMagick_MagickWand_INCLUDE_DIR:PATH=/usr/include/ImageMagick-6 \
-DImageMagick_MagickWand_LIBRARY:FILEPATH=/usr/lib/ \
-DImageMagick_MagickCore_INCLUDE_DIR:PATH=/usr/include/ImageMagick-6 \
Comment by Rudolf Polzer (rpolzer) - Wednesday, 15 May 2013, 17:34 GMT
I can confirm this workaround in kxstitch-kde4 in AUR. However, I also had to add


to shut off multiple screenfuls of deprecation warnings, as these preprocessor macros are now required. Of course, even cmake in git does not add these flags yet...
Comment by Andrea Scarpino (BaSh) - Friday, 17 May 2013, 19:00 GMT
status with cmake 2.8.11?
Comment by Antonio Rojas (arojas) - Saturday, 18 May 2013, 09:32 GMT
With cmake 2.8.11 ImageMagick is detected, but the ImageMagick_INCLUDE_DIRS variable is not set correctly.
This makes kipi-plugins compilation fail, because it looks for /usr/include/magick/api.h instead of /usr/include/ImageMagick-6/magick/api.h
Comment by Antonio Rojas (arojas) - Sunday, 02 June 2013, 21:20 GMT
The include dir detection has been fixed upstream;a=commitdiff;h=3de9bb48