Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35254 - [gtkmm] gtkmm-2.24.3-1-x86_64 appears to break vmware workstation

Attached to Project: Arch Linux
Opened by Jeremiah Baughman (stilljb) - Monday, 13 May 2013, 22:46 GMT
Last edited by Laurent Carlier (lordheavy) - Friday, 28 June 2013, 13:56 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 16
Private No

Details

Description: When upgrading to gtkmm-2.24.3-1-x86_64 from gtkmm-2.24.2-2-x86_64, vmware workstation 9.02 "core dumps" on start (It does not actually leave a core dump file).

Downgrading to gtkmm-2.24.2-2 fixes the issue


Additional info:
Part of me hates to put anything about vmware here, since it is obviously closed source and NOT part of Arch in any way, but I don't know where else I should post this.


Steps to reproduce:
Upgrade to gtkmm-2.24.3-1 and try to start vmware.
This task depends upon

Closed by  Laurent Carlier (lordheavy)
Friday, 28 June 2013, 13:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  gtkmm 2.24.4-1
Comment by Nikita Boldasov (ReNoM) - Tuesday, 14 May 2013, 13:04 GMT
I have a same problem with another vmware software:
https://aur.archlinux.org/packages/vmware-vsphere-web-client-plugin/
Comment by Jelle van der Waa (jelly) - Tuesday, 14 May 2013, 19:44 GMT
Without error output we probably can't do much about the problem.
Comment by Jeremiah Baughman (stilljb) - Tuesday, 14 May 2013, 22:13 GMT
What error output would you like. I should have a little time in the morning to put things back and debug a little. I can say that in the strace output there was a SIGSEGV reported right before the crash. I have the strace output but that by itself will probably not be too helpful.
Comment by Artjom Simon (artjom.simon) - Wednesday, 15 May 2013, 00:39 GMT
See  FS#35293  for gdb backtrace of dumped core.
Comment by Valentino Pistis (zappa) - Saturday, 18 May 2013, 21:38 GMT
I have the same problem...but...I don't have the older gtkmm-2.24.2-2.
I have deleted pacman cache some weeks ago :)
Where I can find it?
Comment by Valentino Pistis (zappa) - Saturday, 18 May 2013, 21:58 GMT
...oops... OK! Found the old pkg in ARM :P
for me the downgrade is a solution!

thanx
Comment by Jelle van der Waa (jelly) - Monday, 20 May 2013, 08:31 GMT
gsmartcontrol breaks when compiling with gtkmm-2.24.3 and builds fine with the previous gtkmm version. I suspect there is something wrong in the new release.
Gsmartcontrol bug https://bugs.archlinux.org/task/35371
Comment by Jelle van der Waa (jelly) - Monday, 20 May 2013, 11:22 GMT
It looks like gtkmm is broken in general. https://bugzilla.gnome.org/show_bug.cgi?id=700699
Comment by Clouseau2 (Clouseau2) - Tuesday, 21 May 2013, 12:22 GMT
I can also confirm this, on VMware Vsphere Web Remote console plugin. Althou the web gui works (with occasional unresponsivness) the launch console is broken, it just hangs saying connection and then popups the Error regarding NPObject. When gtkmm is downgraded, everything works...
Comment by Florian (wespe) - Thursday, 23 May 2013, 06:19 GMT
Same problem, same solution: VMware Workstation 9.0.2 crashes on startup, downgrading to 2.24.2-2 solves the problem.
Comment by jose (matrs) - Tuesday, 28 May 2013, 22:16 GMT
Confirmed here, vmware workstation 9.0.2 build-1031769 "core dumps" on start with gtkmm-2.24.3-1-x86_64 and downgrading to gtkmm-2.24.2-2-x86_64 fix the problem.
Comment by Anton Eliasson (eliasson) - Wednesday, 29 May 2013, 10:24 GMT
Okay people, I think we can stop confirming this bug now since it's already being worked on upstream (see jelly's link to Gnome Bugzilla). Simply click "(watch task)" above and you'll be notified when a fix gets released.
Comment by Robert Charlton (rectec) - Friday, 21 June 2013, 04:58 GMT
Can someone upload their older gtkmm package here?

I don't have the older package in my cache. I've kept everything in the cache since I installed this system, but I installed it on June 1st (by then the defective version of gtkmm had already made it onto the repos).

I've tried building from this source: http://ftp.gnome.org/pub/gnome/sources/gtkmm/2.24/gtkmm-2.24.2.tar.xz (after extracting it of course.)
But for some reason it didn't install the actual library (libgtkmm-2.4.so.1) after I sudo make install'd. Not sure why. I don't know much about building from source. Too lazy to find out why it did this, and it would be an order of magnitude better if I could just install the actual Pacman package instead.

Thanks.
Comment by Nikita Boldasov (ReNoM) - Friday, 21 June 2013, 05:25 GMT
hello Robert Charlton. I have x86_64 package - http://www.renom.info/files/gtkmm-2.24.2-2-x86_64.pkg.tar.xz
Comment by Robert Charlton (rectec) - Friday, 21 June 2013, 11:37 GMT
Much appreciated. :)
Comment by Sebastian (quizzmaster) - Friday, 21 June 2013, 13:25 GMT
Please look at this: https://wiki.archlinux.org/index.php/Downgrading_Packages#Arch_Rollback_Machine
There are all informations how to downgrade packages..
Comment by Christian Hesse (eworm) - Tuesday, 25 June 2013, 08:29 GMT
Ok, this took me some time... Needed it for mysql-workbench which had been broken as well.
Now gtkmm compiles fine and even mysql-workbench is happy again.
Comment by Nikita Boldasov (ReNoM) - Tuesday, 25 June 2013, 10:33 GMT
Christian Hesse, it's don't help to me.
Comment by Jelle van der Waa (jelly) - Friday, 28 June 2013, 09:32 GMT
gtkmm 2.24.4 is released which fixed this problem. I can compile + run gsmartcontrol.

Loading...