Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35246 - [midori] does not show context menu

Attached to Project: Community Packages
Opened by Christian Hesse (eworm) - Monday, 13 May 2013, 14:23 GMT
Last edited by Alexander F. Rødseth (xyproto) - Monday, 20 May 2013, 20:49 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Alexander F. Rødseth (xyproto)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Midori does not show context menu on right-click.

Additional info:
community/midori 0.5.0-2

Steps to reproduce:
* open website
* right-click on site or on link
This task depends upon

Closed by  Alexander F. Rødseth (xyproto)
Monday, 20 May 2013, 20:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  Upstream fixed it for 0.5.2.
Comment by Christian Hesse (eworm) - Monday, 13 May 2013, 14:48 GMT
Looks like this is caused by upstream commit:

commit ea2ba1945057936372ed2ea5eaebc3c5ae90e1c7
Author: Christian Dywan <christian@twotoasts.de>
Date: Tue Mar 26 08:26:21 2013 +0100

Implement direction-based mouse gesture configuration
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 15 May 2013, 09:23 GMT
Thanks for reporting. Unable to reproduce.

Does the problem go away if you try midori-git or midori-gtk2-git from AUR?
Comment by Christian Hesse (eworm) - Wednesday, 15 May 2013, 09:38 GMT
No, git checkout has the same problem.

But I just noticed this only happens if the mouse gestures plugin is enabled... However, it worked before the commit mentioned above.

Reported this upstream:
https://bugs.launchpad.net/midori/+bug/1179540
Comment by Alexander F. Rødseth (xyproto) - Wednesday, 15 May 2013, 09:48 GMT
Ok, will wait for upstream to create a new release. Thanks.
Comment by Christian Hesse (eworm) - Wednesday, 15 May 2013, 20:15 GMT Comment by Alexander F. Rødseth (xyproto) - Monday, 20 May 2013, 20:49 GMT
midori is now at 0.5.2, which was released after the upstream fix (tagged as 0.5.1). Please reopen if this is still problematic.

Loading...