Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35240 - [Gnome] crashes with kernel 3.9.x

Attached to Project: Arch Linux
Opened by Guillermo Leira (gleira) - Monday, 13 May 2013, 09:47 GMT
Last edited by Jan Steffens (heftig) - Thursday, 06 June 2013, 16:40 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan Steffens (heftig)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:

Gnome 3.8.1 crashes with kernels 3.9.x. I tried with version 3.9 and 3.9.1 when they were in testing,
and now with 3.9.2. I get a "something went wrong and gnome has to close".

Downgrading to 3.8.11 solves the problem.

Xfce works fine.

And other computers with same configuration (different hardware) work fine.

Video card:
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)

Additional info:
* package version(s)

kernels 3.9.x

* config and/or log files etc.

Please, tell me what files could be useful.


Steps to reproduce:
Install any kernel 3.9.x
This task depends upon

Closed by  Jan Steffens (heftig)
Thursday, 06 June 2013, 16:40 GMT
Reason for closing:  Fixed
Comment by Ebubekir KARUL (EbubekirK) - Monday, 13 May 2013, 10:17 GMT
I'm updated to kernel 3.9.x and reboot, I don't have any error or problem for now.
Comment by Guillermo Leira (gleira) - Monday, 13 May 2013, 10:32 GMT
I also have another four computers working fine with kernel 3.9.2 and gnome 3.8.1, but my laptop fails with all 3.9.x kernels.
Comment by Jörgen Jonsson (lionking62) - Tuesday, 14 May 2013, 08:34 GMT
Same problem with my laptop HP 8530w
Comment by Martin Kühn (mkuehn) - Tuesday, 14 May 2013, 19:10 GMT
I have the same problem with my HP 8710p laptop (Core 2 Duo T7300, NVIDIA Quadro NVS 320M).
Comment by Jelle van der Waa (jelly) - Tuesday, 14 May 2013, 19:45 GMT
We need your xorg.0.log if it has anything interesting in it, else we can't debug this problem.
Comment by Martin Kühn (mkuehn) - Wednesday, 15 May 2013, 04:54 GMT
There are no errors in Xorg.0.log. Gnome-shell starts and displays the following warning
Oh no! Something has gone wrong.
A Problem has occurred and the System can't recover.
Please log out and try again
All you can do is to press the Log Out button.

journalctl -b shows (full log attached)

<code>
Mai 14 22:27:17 arch64.lan colord[561]: Profile added: icc-8298763041cd24a0ef9da6f2cd97e9ab
Mai 14 22:27:17 arch64.lan colord[561]: Profile added: icc-3c219b18958837493b586581f8c2a2a4
Mai 14 22:27:17 arch64.lan colord[561]: Device added: xrandr-LG Philips
Mai 14 22:27:17 arch64.lan colord[561]: Profile added: icc-324a2cf21d21aa0455e72a71e8e75c62
Mai 14 22:27:17 arch64.lan colord[561]: Automatic metadata add icc-014995ed67deca192018c3ec59e011ec to xrandr-LG Philips
Mai 14 22:27:17 arch64.lan colord[561]: Profile added: icc-014995ed67deca192018c3ec59e011ec
Mai 14 22:27:20 arch64.lan gnome-session[426]: WARNING: Application 'gnome-shell.desktop' killed by signal 6
Mai 14 22:27:20 arch64.lan systemd-coredump[606]: Process 550 (gnome-shell) dumped core.
Mai 14 22:27:21 arch64.lan gnome-session[426]: Unrecoverable failure in required component gnome-shell.desktop
Mai 14 22:27:21 arch64.lan systemd-coredump[628]: Process 613 (gnome-shell) dumped core.
Mai 14 22:27:22 arch64.lan systemd-coredump[642]: Process 448 (gnome-settings-) dumped core.
Mai 14 22:27:22 arch64.lan gnome-session[426]: Entering running state
Mai 14 22:27:21 arch64.lan gnome-session[426]: WARNING: Application 'gnome-shell.desktop' killed by signal 6
Mai 14 22:27:21 arch64.lan gnome-session[426]: WARNING: App 'gnome-shell.desktop' respawning too quickly
Mai 14 22:27:21 arch64.lan goa[626]: goa-daemon version 3.8.2 starting [main.c:113, main()]
Mai 14 22:27:22 arch64.lan colord[561]: device removed: xrandr-LG Philips
Mai 14 22:27:22 arch64.lan colord[561]: Profile removed: icc-324a2cf21d21aa0455e72a71e8e75c62
Mai 14 22:27:22 arch64.lan colord[561]: Profile removed: icc-014995ed67deca192018c3ec59e011ec
Mai 14 22:27:22 arch64.lan gnome-session[426]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 5
Mai 14 22:27:23 arch64.lan colord[561]: Device added: xrandr-LG Philips
Mai 14 22:27:23 arch64.lan colord[561]: Profile added: icc-324a2cf21d21aa0455e72a71e8e75c62
Mai 14 22:27:23 arch64.lan colord[561]: Automatic metadata add icc-014995ed67deca192018c3ec59e011ec to xrandr-LG Philips
Mai 14 22:27:23 arch64.lan colord[561]: Profile added: icc-014995ed67deca192018c3ec59e011ec
Mai 14 22:28:23 arch64.lan ntpd_intres[342]: host name not found: 0.pool.ntp.org
Mai 14 22:28:23 arch64.lan ntpd_intres[342]: host name not found: 1.pool.ntp.org
Mai 14 22:28:23 arch64.lan ntpd_intres[342]: host name not found: 2.pool.ntp.org
Mai 14 22:28:23 arch64.lan kernel: traps: gnome-settings-[448] trap int3 ip:7fa44b89ceed sp:7fff1ef246d0 error:0
Mai 14 22:28:33 arch64.lan colord[561]: device removed: xrandr-LG Philips
Mai 14 22:28:33 arch64.lan colord[561]: Profile removed: icc-324a2cf21d21aa0455e72a71e8e75c62
Mai 14 22:28:33 arch64.lan colord[561]: Profile removed: icc-014995ed67deca192018c3ec59e011ec
Mai 14 22:28:43 arch64.lan kernel: opera[669]: segfault at 21 ip 0000000000000021 sp 00007fff6cf7b2e8 error 14 in opera[400000+15b6000]
Mai 14 22:28:43 arch64.lan systemd-coredump[720]: Process 639 (opera) dumped core.
</code>
Comment by Jan Steffens (heftig) - Wednesday, 15 May 2013, 07:26 GMT
Seems gnome-settings-daemon is crashing. Try running it in GDB from your Xfce session.
Comment by JB (techryda) - Thursday, 16 May 2013, 03:27 GMT
Here's the GDB output, let me know what other info might be helpful (I ran this in an OpenBox session):

$ gdb /usr/lib/gnome-settings-daemon/gnome-settings-daemon
GNU gdb (GDB) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/gnome-settings-daemon/gnome-settings-daemon...(no debugging symbols found)...done.
(gdb) run
Starting program: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffe9f0a700 (LWP 3299)]
[New Thread 0x7fffe94fd700 (LWP 3300)]
[New Thread 0x7fffe8cfc700 (LWP 3301)]
[New Thread 0x7fffdb390700 (LWP 3302)]

** (gnome-settings-daemon:3295): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (process:3308): WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[Thread 0x7fffe8cfc700 (LWP 3301) exited]
[Thread 0x7fffdb390700 (LWP 3302) exited]
Comment by Martin Kühn (mkuehn) - Thursday, 16 May 2013, 05:15 GMT
No crash occurs when I run gnome-settings-daemon under Xfce. Here is my gdb output:

[mmk@arch64 ~]$ gdb /usr/lib/gnome-settings-daemon/gnome-settings-daemon
GNU gdb (GDB) 7.6
Copyright (C) 2013 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-unknown-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /usr/lib/gnome-settings-daemon/gnome-settings-daemon...(no debugging symbols found)...done.
(gdb) set target-async on
(gdb) r&
Starting program: /usr/lib/gnome-settings-daemon/gnome-settings-daemon
warning: no loadable sections found in added symbol-file system-supplied DSO at 0x7ffff7ffa000
(gdb) warning: Could not load shared library symbols for linux-vdso.so.1.
Do you need "set solib-search-path" or "set sysroot"?
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
[New Thread 0x7fffebb61700 (LWP 518)]
[New Thread 0x7fffeb360700 (LWP 519)]
[New Thread 0x7fffeab5f700 (LWP 520)]
[New Thread 0x7fffdb399700 (LWP 521)]

** (gnome-settings-daemon:514): WARNING **: You can only run one xsettings manager at a time; exiting

** (gnome-settings-daemon:514): WARNING **: Unable to start gnome_xsettings manager: Could not initialize xsettings manager.
[Thread 0x7fffdb399700 (LWP 521) exited]

** (gnome-settings-daemon:514): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

(gnome-settings-daemon:514): clipboard-plugin-WARNING **: Clipboard manager is already running.

(gdb)
** (process:524): WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
[New Thread 0x7fffdb399700 (LWP 552)]

(gdb) [Thread 0x7fffdb399700 (LWP 552) exited]
info thread
Id Target Id Frame
4 Thread 0x7fffeab5f700 (LWP 520) "gdbus" (running)
3 Thread 0x7fffeb360700 (LWP 519) "pool" (running)
2 Thread 0x7fffebb61700 (LWP 518) "dconf worker" (running)
1 Thread 0x7ffff7f9b8c0 (LWP 514) "gnome-settings-" (running)

The current thread <Thread ID 6> has terminated. See `help thread'.
(gdb) [Thread 0x7fffeb360700 (LWP 519) exited]

Id Target Id Frame
4 Thread 0x7fffeab5f700 (LWP 520) "gdbus" (running)
2 Thread 0x7fffebb61700 (LWP 518) "dconf worker" (running)
1 Thread 0x7ffff7f9b8c0 (LWP 514) "gnome-settings-" (running)
Comment by Martin Kühn (mkuehn) - Thursday, 16 May 2013, 20:46 GMT
I tired to start gnome-session with xinit and it worked. With gdm or startx gnome always crashes on my laptop.
The output of journalctl still shows some errors:

Mai 16 21:24:54 arch64.lan dbus-daemon[254]: dbus[254]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-daemon.service'
Mai 16 21:24:54 arch64.lan dbus[254]: [system] Activating via systemd: service name='org.freedesktop.Accounts' unit='accounts-daemon.service'
Mai 16 21:24:54 arch64.lan systemd[1]: Starting Accounts Service...
Mai 16 21:24:54 arch64.lan accounts-daemon[492]: started daemon version 0.6.32
Mai 16 21:24:54 arch64.lan dbus-daemon[254]: dbus[254]: [system] Successfully activated service 'org.freedesktop.Accounts'
Mai 16 21:24:54 arch64.lan dbus[254]: [system] Successfully activated service 'org.freedesktop.Accounts'
Mai 16 21:24:54 arch64.lan systemd[1]: Started Accounts Service.
Mai 16 21:24:56 arch64.lan polkitd[264]: Registered Authentication Agent for unix-session:1 (system bus name :1.22 [gnome-shell --sm-client-id 107ca242561a5e9310136873084825705900000056030000], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale de_DE.UTF-8)
Mai 16 21:24:57 arch64.lan goa[503]: goa-daemon version 3.8.2 starting [main.c:113, main()]
Mai 16 21:24:58 arch64.lan gnome-session[305]: Entering running state
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] DATA_ERROR INVALID_VALUE
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] DATA_ERROR
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] ch 4 [0x000f949000 gnome-shell[435]] subc 3 class 0x8297 mthd 0x0e04 data 0xff310000
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] DATA_ERROR INVALID_VALUE
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] DATA_ERROR
Mai 16 21:25:01 arch64.lan kernel: nouveau E[ PGRAPH][0000:01:00.0] ch 4 [0x000f949000 gnome-shell[435]] subc 3 class 0x8297 mthd 0x0e08 data 0xffe40000
Comment by JB (techryda) - Friday, 17 May 2013, 04:04 GMT
I'm assuming that this issue is hardware specific since more people aren't affected by it.

Going with that assumption, I'll provide some of my h/w info in the hope that it helps narrow down the cause of the issue:

HP/Compaq 6910p

$ lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) (rev 0c)
00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (secondary) (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HM/HEM (ICH8M/ICH8M-E) SATA Controller [AHCI mode] (rev 03)
02:06.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b9)
02:06.1 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev b9)
02:06.2 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 03)
02:06.3 SD Host controller: Ricoh Co Ltd R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter (rev 20)
10:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 02)
Comment by Wolfgang (wurfmaul) - Friday, 17 May 2013, 07:01 GMT
Seems to be a problem that only affects some HP laptop models. I have the same issue with my HP Elitebook 6930p (Intel Core2 Duo CPU P8800 @ 2.66GHz × 2 ). I attached my lspci output.
Moreover I installed Openbox when I first had this problem and I was not able to perform gnome-settings-daemon operations ("Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files"). At least gdm did not seem to have problems at all...
Comment by Jörgen Jonsson (lionking62) - Friday, 17 May 2013, 07:42 GMT
I'm running Fedora on an HP Elitebook 8530w, and just today updates to gnome-bluetooth and control-center solved the problem, running 3.9.2 now.
Comment by JB (techryda) - Friday, 17 May 2013, 09:53 GMT
@lionking62 thanks!

I found the following patch and applied it to gnome-bluetooth and I;m back up and running w gnome.
https://git.gnome.org/browse/gnome-bluetooth/commit/?id=9932a6316be777d47b89323c9b8ae132c3676830

I'll flag gnome-bluetooth out of date w a pointer to this bug.
Comment by JB (techryda) - Friday, 17 May 2013, 10:00 GMT
Just noticed that @heftig is the package maintainer for gnome-bluetooth and the assignee for this bug, sorry for the double report

Thanx!
Comment by JB (techryda) - Friday, 17 May 2013, 20:37 GMT
Working PKGBUILD & patch if anyone's interested
Comment by Chase Oubre (sirkingchase) - Saturday, 18 May 2013, 17:55 GMT
I got gnome to work using the workaround provided here -
https://bbs.archlinux.org/viewtopic.php?pid=1270468

I hope we can get this resolved. What information can I provide to be more useful?
Comment by Jonathan Csanyi (jcsanyi) - Thursday, 06 June 2013, 16:38 GMT
As of gnome-bluetooth 3.8.1, which was released a couple days ago, the patch mentioned above is now in the official packages.
If you manually patched gnome-bluetooth or installed the gnome-bluetooth-git AUR package to work around this problem, you can switch back to the official gnome-bluetooth package now.

I'm now running kernel 3.9.4 with no problems, even though I originally ran into this bug when first upgrading to 3.9.

Loading...