Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35237 - [linux] linux-3.9.2-1-ARCH Failed to poweroff/halt

Attached to Project: Arch Linux
Opened by Iru Dog (mytbk) - Monday, 13 May 2013, 03:54 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 17 September 2013, 09:56 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas Bächler (brain0)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No


I installed linux-3.9.2 just now and found out that system cannot poweroff/halt after filesystems unmounted. But I don't know how to find a log during poweroff.

Additional info:
* package version(s)
* config and/or log files etc.

Steps to reproduce:
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 17 September 2013, 09:56 GMT
Reason for closing:  Fixed
Additional comments about closing:  Please open new entry about your issue.
Comment by Iru Dog (mytbk) - Monday, 13 May 2013, 04:02 GMT
PS: I'm using HP EliteBook 6930p (VF143UC#ABA).
The message displayed is:
All filesystems unmounted.
Deactivating swaps.
All swaps deactivated.
Detaching loop devices.
All loop devices detached.
Detaching DM devices.
All DM devices detached.
Storage is finalized.

Then nothing happens. I can switch the ttys, and can type letters after these messages are showed.
Comment by John (graysky) - Monday, 13 May 2013, 07:16 GMT
Interesting.... I get the following[1] if and only if I am using 300 Hz ticks (the Arch default) and the BFS-patched Arch kernel (1k ticks solves the problem); the stock ARCH kernel does not hang at all.

Experiment #1. Can you build from ABS and switch the tick rate to 1k and see if your laptop still hangs?

Instructions to enable alternative tick rate:
1. Add an nconfig option to the PKGBUILD
2. Processor type and features --->
3. Timer frequency (300 HZ) --->
4. Select 1000 Hz
5. Save, compile, and install

Comment by Iru Dog (mytbk) - Monday, 13 May 2013, 08:24 GMT
Experiment #1.
1. I slimed the kernel with my old config files, it still hangs
2. I used the config in step 1, and changed timer frequency to 1000Hz, it still hangs
Comment by John (graysky) - Monday, 13 May 2013, 08:30 GMT
Experiment #2. Try the linux-ck package and see if it hangs for you as well.
Comment by Iru Dog (mytbk) - Monday, 13 May 2013, 10:17 GMT
I just boostraped a fedora system on a btrfs subvol and installed kernel-3.9.1 in fc19. And the fedora system also hangs when I use the 3.9 kernel.
I first found out this problem when I started to use the linux-ice kernel, but it seems that 3.9-rc didn't have this problem.
Comment by John (graysky) - Monday, 13 May 2013, 19:42 GMT
Perhaps this isn't an Arch bug. Are you planning an upstream bug report?
Comment by Iru Dog (mytbk) - Tuesday, 14 May 2013, 10:02 GMT
I built a linux-ck with previous config and set BFS and BFQ, but still hangs.
I suspect that CONFIG_HP_WMI(originally it was 'm') caused the problem, so I unset CONFIG_STAGING and X86_PLATFORM_DEVICES and rebuilt linux-ck, and it can poweroff now.
Comment by John (graysky) - Tuesday, 14 May 2013, 18:48 GMT
Interesting, two questions:

1) What made you suspect CONFIG_HP_WMI?
2) If you build the stock Arch kernel from ABS making the change to only CONFIG_HP_WMI=y and #CONFIG_STAGING and #X86_PLATFORM_DEVICES, does it work?
Comment by Iru Dog (mytbk) - Wednesday, 15 May 2013, 09:35 GMT
a. I'm using a HP laptop
b. a kernel bug at net/rfkill/core.c:244 emitted during boot, and hp_wmi is in the debug trace

2) I changed CONFIG_HP_WMI to y, but I got a boot failure with 2 kernel bugs(the other is about drm). So I'll try later.
Comment by Iru Dog (mytbk) - Friday, 17 May 2013, 12:01 GMT
I just set the CONFIG_HP_WMI=n and the problem is solved.
Comment by Iru Dog (mytbk) - Saturday, 18 May 2013, 00:26 GMT Comment by Ralf (ralfi) - Friday, 24 May 2013, 21:31 GMT
CONFIG_HP_WMI=n solved the problem on HP nc6400.
Comment by Iru Dog (mytbk) - Friday, 24 May 2013, 23:18 GMT
We can use the following patch, but it hasn't been applied in kernel-3.9.4 yet.
Comment by Rutgerr Howley (rootgerr) - Saturday, 25 May 2013, 00:57 GMT
This behavior occurs sometimes in my system, but is not a hp
Comment by John (graysky) - Saturday, 25 May 2013, 09:21 GMT
I suspect that this is not an Arch bug but one created in 3.9.0 (still present) upstream.

Supporting data: See and the comment after it.
Comment by Flanker (flanker) - Sunday, 02 June 2013, 23:09 GMT
I think there might be a bit of confusion with people experiencing similar symptoms from unrelated issues. :) The problem in this bug happens exactly as Iru Dog described in the initial post and is reproducible on every single shutdown or reboot attempt from an HP notebook. The dmesg identifies hp_wmi in the call trace:

-- snip ---
[ 26.244144] kernel BUG at net/rfkill/core.c:244!
--- snip --
[ 26.247083] Call Trace:
[ 26.247124] [<f878522f>] hp_wmi_bios_setup+0x22f/0x34d [hp_wmi]
--- snip ---

Setting CONFIG_HP_WMI=n will resolve the issue, but of course the real fix is to patch the errors in hp-wmi.c as shown here:

All of the above confirmed on a Hewlett-Packard HP Compaq 2510p Notebook PC/30C9 ... now just waiting for upstream to patch. :)
Comment by Iru Dog (mytbk) - Tuesday, 04 June 2013, 08:55 GMT Comment by Trichy (Trichy) - Friday, 14 June 2013, 09:58 GMT Comment by Iru Dog (mytbk) - Saturday, 15 June 2013, 02:10 GMT
Fixed in linux-3.9.6.
Comment by M.W. (kenubi) - Wednesday, 11 September 2013, 17:32 GMT
  • Field changed: Percent Complete (100% → 0%)
Are you sure?
Long time I used sysv (and grub-legacy, the kernel ..init=..systemd) and recently installed systemd-sysvcompat (and removed "init=" in grub). As soon as I received the same error - the last entry "storage is finalized." (sometimes even "EXT4-fs (sda3): ext4_da_writepages: jbd2_start: 8192 pages, ino 662018; err -30"). My last kernels: 3.10.7, 3.10.9).
My computer is not HP, I have no entry "hp_wmi" in everything.log
My pacman.log/lspci:
[2013-08-23 17:54] [PACMAN] Running 'pacman -Syu'
[2013-08-23 17:54] [PACMAN] synchronizing package lists
[2013-08-23 17:54] [PACMAN] starting full system upgrade
[2013-08-23 17:58] [PACMAN] upgraded chromium (28.0.1500.95-1 -> 29.0.1547.57-1)
[2013-08-23 17:58] [PACMAN] upgraded gendesk (0.5.2-1 -> 0.5.3-1)
[2013-08-23 17:58] [PACMAN] upgraded gnupg (2.0.20-2 -> 2.0.21-1)
[2013-08-23 17:58] [PACMAN] upgraded iagno (3.8.1-1 -> 3.8.2-1)
[2013-08-23 17:58] [PACMAN] upgraded isl (0.12-1 -> 0.12.1-1)
[2013-08-23 17:58] [PACMAN] upgraded kdepim-libkdepim (4.11.0-1 -> 4.11.0-2)
[2013-08-23 17:58] [PACMAN] upgraded kdepim-knode (4.11.0-1 -> 4.11.0-2)
[2013-08-23 17:58] [PACMAN] upgraded libgexiv2 (0.6.1-1 -> 0.6.1-2)
[2013-08-23 17:59] [PACMAN] upgraded libtiff (4.0.3-2 -> 4.0.3-3)
[2013-08-23 17:59] [PACMAN] upgraded libwbclient (4.0.8-1 -> 4.0.9-1)
[2013-08-23 17:59] [PACMAN] upgraded pyqt4-common (4.10.2-2 -> 4.10.3-1)
[2013-08-23 17:59] [PACMAN] upgraded sip (4.14.7-1 -> 4.15-1)
[2013-08-23 17:59] [PACMAN] upgraded python-sip (4.14.7-1 -> 4.15-1)
[2013-08-23 17:59] [PACMAN] upgraded python-pyqt4 (4.10.2-2 -> 4.10.3-1)
[2013-08-23 17:59] [PACMAN] upgraded python2-sip (4.14.7-1 -> 4.15-1)
[2013-08-23 17:59] [PACMAN] upgraded python2-pyqt4 (4.10.2-2 -> 4.10.3-1)
[2013-08-23 17:59] [PACMAN] upgraded smbclient (4.0.8-1 -> 4.0.9-1)
[2013-08-27 11:10] [PACMAN] Running 'pacman -S systemd-sysvcompat'
[2013-08-27 11:11] [PACMAN] Running 'pacman -R sysvinit sysvinit-scripts'
[2013-08-27 11:11] [PACMAN] removed sysvinit-scripts (20130606-1)
[2013-08-27 11:11] [PACMAN] removed sysvinit (2.88-11)
[2013-08-27 11:11] [PACMAN] Running 'pacman -S systemd-sysvcompat'
[2013-08-27 11:11] [PACMAN] installed systemd-sysvcompat (204-3)
[2013-08-28 19:12] [PACMAN] Running 'pacman -Syu'
[2013-08-28 19:12] [PACMAN] synchronizing package lists

00:00.0 Host bridge: Intel Corporation 4 Series Chipset DRAM Controller (rev 03)
00:01.0 PCI bridge: Intel Corporation 4 Series Chipset PCI Express Root Port (rev 03)
00:1b.0 Audio device: Intel Corporation NM10/ICH7 Family High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 1 (rev 01)
00:1c.1 PCI bridge: Intel Corporation NM10/ICH7 Family PCI Express Port 2 (rev 01)
00:1d.0 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #1 (rev 01)
00:1d.1 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #2 (rev 01)
00:1d.2 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #3 (rev 01)
00:1d.3 USB controller: Intel Corporation NM10/ICH7 Family USB UHCI Controller #4 (rev 01)
00:1d.7 USB controller: Intel Corporation NM10/ICH7 Family USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 01)
00:1f.2 IDE interface: Intel Corporation NM10/ICH7 Family SATA Controller [IDE mode] (rev 01)
00:1f.3 SMBus: Intel Corporation NM10/ICH7 Family SMBus Controller (rev 01)
01:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 03)
04:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630] (rev a1)
04:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
Comment by Iru Dog (mytbk) - Wednesday, 11 September 2013, 22:08 GMT
M.W. (kenubi): It should be another problem, my problem is caused by a mistake in hp_wmi.c, so it's not related.