Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35195 - [systemd] systemd binary is in /usr/lib, instead of where executable binaries go

Attached to Project: Arch Linux
Opened by Hugo Osvaldo Barrera (hobarrera) - Saturday, 11 May 2013, 06:26 GMT
Last edited by Dave Reisner (falconindy) - Saturday, 11 May 2013, 15:33 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No



systemd's executable binary is in /usr/lib/systemd.
This has two problems:

1) It's no longer in the $PATH, so many setups which use user-level systemd fail to start up.
2) It's in the wrong place. */lib contains libaries, while */{s,}bin contains binaries.

While I'm going to stay away from flame wars regarding if /bin or /usr/sbin should be used, I definitely belive binaries should generally be:

1) In the default $PATH
2) Not in */lib, */doc /etc...
This task depends upon

Closed by  Dave Reisner (falconindy)
Saturday, 11 May 2013, 15:33 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Nothing wrong here. /bin/systemd was obsoleted by upstream for systemd v44 (over a year ago).
Comment by Allan McRae (Allan) - Saturday, 11 May 2013, 07:33 GMT

"Applications may use a single subdirectory under /usr/lib. If an application uses a subdirectory, all architecture-dependent data exclusively used by the application must be placed within that subdirectory."