Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35187 - [xorg-server] X segfault if a app using SDL run in fullscreen

Attached to Project: Arch Linux
Opened by Pablo Lezaeta (Jristz) - Friday, 10 May 2013, 21:34 GMT
Last edited by Jan de Groot (JGC) - Wednesday, 12 June 2013, 20:34 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
I can reproduce this whit znes (multilib), doukutsu (aur), and airlines-tycoon (buyable, free demo available)
if an app linked to SDL run in full screen cause a X segfault and crash.
all are linked to libSDL and the airlines to a internal (in install dir) old version, but in all cases a full screen make a crash
older versions from X 1.13.1 last to work for me not crash and show that app
no, my video is xf86-video-modesetting

Additional info:
* Xorg-server 1.14.1

Steps to reproduce:
sun a app like sznes in fullscreen without OpenGL
This task depends upon

Closed by  Jan de Groot (JGC)
Wednesday, 12 June 2013, 20:34 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed with xf86-video-modesetting 0.8.0.
Comment by Jelle van der Waa (jelly) - Sunday, 12 May 2013, 09:44 GMT
Which video driver do you use?
Can't reproduce the segfault here.
Comment by Pablo Lezaeta (Jristz) - Sunday, 12 May 2013, 20:49 GMT
xf86-video-modesetting in a gma500 whit KMS
I can reproduce as you want in ALL app with sdl
libSDL-1.2.so.0 => /usr/lib32/libSDL-1.2.so.0

you want any special test or run any special command??
Comment by Jan de Groot (JGC) - Monday, 13 May 2013, 12:09 GMT
Can you provide backtraces? You can usually find these in Xorg.0.log or Xorg.0.log.old. Note that the file could be named different if you're using a display manager like gdm (sometimes your session doesn't run on screen 0).
Comment by Pablo Lezaeta (Jristz) - Monday, 13 May 2013, 21:21 GMT
yes, here are Xorg.0.log and Xorg.0.log.old
the .old one is have a backtrace at 713.676 the exactly momment when I run Zsnes at full screen whitout OpenGL (640x480 DRF) (I thest lower ress whit same result, and Doukutsu (AUR) in fullscreen with any bit depth
Comment by Laurent Carlier (lordheavy) - Monday, 20 May 2013, 09:16 GMT
Please fill a bug upstream https://bugs.freedesktop.org/ then post the link here

Please also consider rebuilding packages with debugging informations enabled. See https://wiki.archlinux.org/index.php/Debug_-_Getting_Traces
Comment by Pablo Lezaeta (Jristz) - Tuesday, 21 May 2013, 03:41 GMT
https://bugs.freedesktop.org/show_bug.cgi?id=64808

I fill a bug upstream I going to try debg as I have time for build (or If arch enable -debug packages ;) )
Comment by Peter Wu (Lekensteyn) - Friday, 24 May 2013, 17:50 GMT
I hit the same issue and have found the reason for the crash already, but do not know how to fix it. This is an upstream bug.
Comment by Laurent Carlier (lordheavy) - Friday, 24 May 2013, 18:00 GMT
@Peter Wu

It is better to put a link to a bugreport or some informations.
Such comment is only annoying and useless, please avoid.
Comment by Peter Wu (Lekensteyn) - Friday, 24 May 2013, 19:30 GMT
@Laurent Please see the comment before my post, thanks. For your convenience, I will paste the bug URL here again:

https://bugs.freedesktop.org/show_bug.cgi?id=64808
Comment by Laurent Carlier (lordheavy) - Wednesday, 12 June 2013, 19:08 GMT
Please check with xf86-video-modesetting-0.8.0
Comment by Peter Wu (Lekensteyn) - Wednesday, 12 June 2013, 20:16 GMT
Yes, I tried it already from git. I am no longer able to crash QEMU 1.4.1 by going full-screen.

Loading...