Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35174 - [gnome-shell] Opening Nautilus 3.8.1 crashes gnome-shell

Attached to Project: Arch Linux
Opened by Britt Yazel (brittyazel) - Friday, 10 May 2013, 02:30 GMT
Last edited by Jan Steffens (heftig) - Thursday, 27 June 2013, 04:02 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
When opening Nautilus, often times (but not every time) gnome-shell will crash to a black screen and be forced to restart. Any open windows will loose their window borders temporarilly until gnome-shell restarts. Also, at certain times the gnome-shell will fully crash, and a full crash occurs forcing the user to click logout, loosing any open work. This regularly happens when opening nautilus, about 75% of the time, though it tends to happen much more often when you have drives mounted from my experience. I do not know what logs to post for this issue, but it is very disconcerting and is one of the last remaining bugs on the Gnome 3.8 desktop.

These are some of the forum postings concerning this issue:

https://bbs.archlinux.org/viewtopic.php?pid=1264986
https://bbs.archlinux.org/viewtopic.php?id=161895


Additional info:
* package version(s) Nautilus 3.8.1-1, Gnome-Shell 3.8.1-1

This task depends upon

Closed by  Jan Steffens (heftig)
Thursday, 27 June 2013, 04:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.8.3-2
Comment by Jan Steffens (heftig) - Friday, 10 May 2013, 07:35 GMT
Works for me.
Comment by Britt Yazel (brittyazel) - Friday, 10 May 2013, 07:54 GMT
I can verify this issue on two different machines, one of which having just had arch reinstalled and having the issue both times.
Comment by Jason Russell (jrussell) - Friday, 10 May 2013, 11:29 GMT
Happens to me on two different computers too, one with nouveau and one with ati drivers if that's any help, with latest packages as of right now.
Comment by Jan Steffens (heftig) - Friday, 10 May 2013, 11:39 GMT
Can reproduce now: Happens when Nautilus is the opened on an empty workspace (i.e. no other windows).
Comment by Jan Steffens (heftig) - Friday, 10 May 2013, 11:40 GMT
Upstream bugs:
https://bugzilla.gnome.org/show_bug.cgi?id=610279
https://bugzilla.gnome.org/show_bug.cgi?id=695030
https://bugzilla.gnome.org/show_bug.cgi?id=699097

This stuff is also a top crasher in Fedora 18, so I guess something will be done sooner or later.
Comment by Britt Yazel (brittyazel) - Friday, 10 May 2013, 15:16 GMT
Its a shame, because it is a HUGE sore on my gnome experience right now... Is there any patch we could apply to fix this until upstream works it out?
Comment by Britt Yazel (brittyazel) - Saturday, 11 May 2013, 03:29 GMT
As was commented by darkxst in the upstream bug report (https://bugzilla.gnome.org/show_bug.cgi?id=695030), this issue is activated primarilly when there are no windows open prior to launching nautilus, and it does not look restricted to Arch, but rather all Gnome.

What is the policy for upstream bugs that are this severe? Do we wait for a new version bump from upstream for a potential fix, or do we patch ourselves?
Comment by Britt Yazel (brittyazel) - Saturday, 25 May 2013, 08:15 GMT
I am using Nemo in place of nautilus until this bug gets fixed. It does not seem to have any attention from the Gnome Developers despite being a fairly large bug. However, using Nemo is a decent solution in the meanwhile, as opposed to jumping ship to KDE for the time being which I am close to being tempted to do.
Comment by Peter Weber (hoschi) - Saturday, 25 May 2013, 11:16 GMT
I confirm this bug. It *only* happens if Nautilus is the first application which gets started.
Comment by Jan Steffens (heftig) - Saturday, 25 May 2013, 15:13 GMT
Upstream has trouble reproducing this. We already know that one condition is that Nautilus needs to be the only window. Are there any others?
Comment by Jason Russell (jrussell) - Saturday, 25 May 2013, 16:33 GMT
For me it crashes when launching nautilus and there are no other windows in gnome-shell (not necessarily just when it's the first app which gets started), happens at any time for me.

Sometimes it crashes by just loosing window borders and everything else of gnome shell, then it fixes itself having lost the nautilus window.
Other times the entire shell re-zoomes in as if its been logged in again, with no nautilus afterwards
And then after a few crashes I get "Oh no........." Grey screen and I'm logged out.
Comment by Britt Yazel (brittyazel) - Saturday, 25 May 2013, 16:37 GMT
The bug only happens when nautilus is the only gtk window open (things like Firefox can still be open for the crash to occur). Also, nautilus must be launched from gnome-shell, launching via terminal does not result in an error at all.
Comment by Britt Yazel (brittyazel) - Saturday, 01 June 2013, 20:51 GMT
I am no longer able to reproduce this bug.... did someone make a change? I think the only major change that I did to my system was upgrading to catalyst 13.6 and then subsequently xorg 1.14, but this issue seemed to not be dependent on video drivers... weird..I cannot make it crash anymore
Comment by Jan Steffens (heftig) - Saturday, 01 June 2013, 21:50 GMT
Still reproducible here.
Comment by Britt Yazel (brittyazel) - Sunday, 02 June 2013, 01:42 GMT
Hrm weird...the only difference between our two gnome builds would be that I have the Catalyst-gnome repo installed and you do not...could it be something with the way those packages in the repo are compiled that fixes it?
Comment by Britt Yazel (brittyazel) - Sunday, 02 June 2013, 05:34 GMT
well it was too good to be true...the problem came is back (or by a random chance just calmed down for a short while)
Comment by Brandon Watkins (bwat47) - Saturday, 22 June 2013, 16:12 GMT
Using gnome is beginning to feel like an eternal beta-test. The shell developer on the upstream bug report made one half-assed attempt to reproduce it and that was it. (even though its quite easy to reproduce and does not seem distro or hardware related)

Let me guess what will happen with this bug based on my experiences with the handling of critical bugs in gnome 3.x:

months from now a developer will finally say its fixed, but we will have to wait until gnome 3.10 to get it.

/rant
Comment by Peter Weber (hoschi) - Sunday, 23 June 2013, 14:06 GMT
Please stay on topic. I know it hurts, but this kind of discussion should happen on the forums or mailing-lists.

Loading...