Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35157 - gdk-pixbuf2 requires libpng15.so.15

Attached to Project: Arch Linux
Opened by Adam (adambot) - Wednesday, 08 May 2013, 13:17 GMT
Last edited by Ionut Biru (wonder) - Wednesday, 08 May 2013, 19:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
when updating gdk-pixbuf2 an error is reported onscreen:

( 6/31) upgrading gdk-pixbuf2 [########################################] 100%
g_module_open() failed for /usr/lib/gdk-pixbuf-2.0/2.10.0/loaders/libpixbufloader-svg.so: libpng15.so.15: cannot open shared object file: No such file or directory



Additional info:
* package version(s)
gdk-pixbuf2-2.28.1-2

Steps to reproduce:
update gdk-pixbuf2 (2.28.1-1 -> 2.28.1-2)
This task depends upon

Closed by  Ionut Biru (wonder)
Wednesday, 08 May 2013, 19:29 GMT
Reason for closing:  Not a bug
Comment by Adam (adambot) - Wednesday, 08 May 2013, 13:21 GMT
reinstalling does not cause this issue:




==> Package upgrade only (new release):
extra/gdk-pixbuf2 2.28.1-2 2 -> 2

==> Continue upgrade ? [Y/n]
==> [V]iew package detail [M]anually select packages
==> --------------------------------------------------
==> y
warning: gdk-pixbuf2-2.28.1-2 is up to date -- reinstalling
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...

Packages (1): gdk-pixbuf2-2.28.1-2

Total Installed Size: 3.67 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring [########################################] 100%
(1/1) checking package integrity [########################################] 100%
(1/1) loading package files [########################################] 100%
(1/1) checking for file conflicts [########################################] 100%
(1/1) checking available disk space [########################################] 100%
(1/1) reinstalling gdk-pixbuf2 [########################################] 100%

$
Comment by Ionut Biru (wonder) - Wednesday, 08 May 2013, 13:27 GMT
that's because at the time when gdk-pixbuf2 was updated, librsvg wasn't until later in the list.
in the end, everything is fine.
Comment by Adam (adambot) - Wednesday, 08 May 2013, 17:01 GMT
since that is the case, then is it possible to add version dependencies in pacman? (so that the list would update dependencies first then packages?)
Comment by Dave Reisner (falconindy) - Wednesday, 08 May 2013, 17:18 GMT
No. It would be far more useful to fix  FS#32764 .

Loading...