Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35112 - [kmail] gpgme 1.4.0 causes KMail signature validation and signed mail composition to fail

Attached to Project: Arch Linux
Opened by Nicky726 (Nicky726) - Monday, 06 May 2013, 10:03 GMT
Last edited by Tobias Powalowski (tpowa) - Tuesday, 06 August 2013, 16:09 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Tobias Powalowski (tpowa)
Andrea Scarpino (BaSh)
Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

After upgrade of gpgme to 1.4.0-1, KMail is no longer able to validate x.509 signed mails (message vaiting for signature validation appears and no validation is done). When composing a signed message, after the private key password is provided a "busy mouse coursor" is displayed over the message window for infinite time, resulting in need of killing KMail as it does not respond.

Additional info:
kdepim-kmail 4.10.2-2
gpgme 1.4.0-1

When KMail is run from console, nothing related is printed after the problematic action. From what I understand of KWatchGnuPG the certificate validation happens and succeedes.


Steps to reproduce:
- in KMail open a x.509 signed message and see the "wait for signature validation message".
- try to compose a new x.509 signed message, when send is pressed, see the KMail stop responding and the message window not disapearing.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Tuesday, 06 August 2013, 16:09 GMT
Reason for closing:  Fixed
Additional comments about closing:  1.4.2-2
Comment by Nicky726 (Nicky726) - Monday, 06 May 2013, 10:33 GMT
Forgot to mention that downgrading gpgme to 1.3.2-1 solves the issue.
I'm including a log from KWatchGnuPG when opening a signed mail in KMail (12:33:35). The validation seems to succede, but there are plenty of other errors around spamming the log all the time (broken pipe and scd card error).
   gpg.log (20.6 KiB)
Comment by Andrea Scarpino (BaSh) - Monday, 06 May 2013, 16:07 GMT
Please report this upstream and paste its link here.
Comment by Nicky726 (Nicky726) - Monday, 06 May 2013, 17:01 GMT
It has been already reported [1]. I should search better next time.
[1] https://bugs.kde.org/show_bug.cgi?id=318116
Comment by Olaf the Lost Viking (olaf.lostviking) - Monday, 29 July 2013, 13:48 GMT Comment by Olaf the Lost Viking (OlafLostViking) - Monday, 29 July 2013, 13:49 GMT
So it looks like we need another configure option at compile time?
Comment by sergio (sergio) - Sunday, 04 August 2013, 17:43 GMT
gpgme configured with ./configure --prefix=/usr --disable-static --disable-fd-passing
indeed works

Loading...