Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35091 - [linux] 3.9.0 acpi-cpufreq module load error.

Attached to Project: Arch Linux
Opened by Yangtse Su (yangtsesu) - Saturday, 04 May 2013, 02:12 GMT
Last edited by Tobias Powalowski (tpowa) - Monday, 06 May 2013, 09:23 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

kernel 3.9.0
# modprobe acpi-cpufreq show device is busy.
ondemand is missing.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Monday, 06 May 2013, 09:23 GMT
Reason for closing:  Not a bug
Additional comments about closing:  It's a new driver
Comment by Tobias Powalowski (tpowa) - Saturday, 04 May 2013, 06:42 GMT
zcat /proc/config.gz| grep ONDEM
CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
All in the kernel.

Is acpi-cpufreq already loaded on your pc?
Comment by Yangtse Su (yangtsesu) - Saturday, 04 May 2013, 13:10 GMT
lsmod shows no.
Comment by Tobias Powalowski (tpowa) - Saturday, 04 May 2013, 17:26 GMT
Does any other driver claim the device?
Comment by Dave Reisner (falconindy) - Saturday, 04 May 2013, 17:47 GMT
> Does any other driver claim the device?
Invariably yes... the output of lsmod will confirm this.
Comment by Yangtse Su (yangtsesu) - Sunday, 05 May 2013, 09:11 GMT
# lsmod
Module Size Used by
fuse 70985 3
joydev 9695 0
hid_generic 1153 0
iTCO_wdt 5407 0
iTCO_vendor_support 1929 1 iTCO_wdt
sparse_keymap 3114 0
pci_hotplug 22930 0
arc4 2000 2
nls_cp437 5953 1
vfat 10119 1
fat 49357 1 vfat
intel_powerclamp 8802 0
coretemp 6102 0
kvm_intel 125373 0
ath9k 100285 0
snd_hda_codec_hdmi 29298 1
kvm 389752 1 kvm_intel
snd_hda_codec_realtek 30733 1
ath9k_common 2096 1 ath9k
ath9k_hw 373150 2 ath9k_common,ath9k
usbhid 40892 0
ath 15489 3 ath9k_common,ath9k,ath9k_hw
crc32_pclmul 3019 0
hid 87539 2 hid_generic,usbhid
ghash_clmulni_intel 4501 0
cryptd 8537 1 ghash_clmulni_intel
mac80211 487534 1 ath9k
psmouse 84588 0
serio_raw 5041 0
i2c_i801 11269 0
pcspkr 2027 0
cfg80211 452044 3 ath,ath9k,mac80211
snd_hda_intel 35816 3
rfkill 15626 3 cfg80211
snd_hda_codec 145640 3 snd_hda_codec_realtek,snd_hda_codec_hdmi,snd_hda_intel
ac 2536 0
r8169 56263 0
snd_hwdep 6364 1 snd_hda_codec
snd_pcm 76860 3 snd_hda_codec_hdmi,snd_hda_codec,snd_hda_intel
mii 4059 1 r8169
snd_page_alloc 7330 2 snd_pcm,snd_hda_intel
snd_timer 18687 1 snd_pcm
lpc_ich 12849 0
mei 58110 0
snd 58893 13 snd_hda_codec_realtek,snd_hwdep,snd_timer,snd_hda_codec_hdmi,snd_pcm,snd_hda_codec,snd_hda_intel
soundcore 5418 1 snd
fan 2753 0
thermal 8588 0
battery 6970 0
wmi 8347 0
evdev 9912 13
usbip_host 18213 0
usbip_core 17145 1 usbip_host
microcode 13204 0
mperf 1267 0
processor 27555 0
crc32c_intel 14249 0
ehci_pci 4120 0
btrfs 787437 2
crc32c 1736 1
libcrc32c 1002 1 btrfs
xor 11824 1 btrfs
zlib_deflate 20476 1 btrfs
raid6_pq 91142 1 btrfs
i915 561573 3
video 11138 1 i915
button 4669 1 i915
i2c_algo_bit 5391 1 i915
intel_agp 10936 1 i915
intel_gtt 12664 2 i915,intel_agp
drm_kms_helper 35086 1 i915
drm 230264 4 i915,drm_kms_helper
i2c_core 22479 5 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit
ehci_hcd 47407 1 ehci_pci
usbcore 176995 4 ehci_hcd,ehci_pci,usbhid,usbip_host
sd_mod 30826 4
usb_common 954 1 usbcore
ahci 22696 3
libahci 21201 1 ahci
libata 169962 2 ahci,libahci
scsi_mod 129660 2 libata,sd_mod

# modinfo acpi-cpufreq
filename: /lib/modules/3.9.0-2-ARCH/kernel/drivers/cpufreq/acpi-cpufreq.ko.gz
alias: acpi
license: GPL
description: ACPI Processor P-States Driver
author: Paul Diefenbaugh, Dominik Brodowski
alias: x86cpu:vendor:*:family:*:model:*:feature:*00E8*
alias: x86cpu:vendor:*:family:*:model:*:feature:*0016*
depends: processor,mperf
intree: Y
vermagic: 3.9.0-2-ARCH SMP preempt mod_unload modversions
parm: acpi_pstate_strict:value 0 or non-zero. non-zero -> strict ACPI checks are performed during frequency changes. (uint)

# modprobe acpi-cpufreq
modprobe: ERROR: could not insert 'acpi_cpufreq': Device or resource busy
Comment by Yangtse Su (yangtsesu) - Sunday, 05 May 2013, 09:24 GMT
$ cpupower frequency-info
analyzing CPU 0:
driver: intel_pstate
CPUs which run at the same hardware frequency: 0
CPUs which need to have their frequency coordinated by software: 0
maximum transition latency: 0.97 ms.
hardware limits: 800 MHz - 2.10 GHz
available cpufreq governors: performance, powersave
current policy: frequency should be within 800 MHz and 2.10 GHz.
The governor "powersave" may decide which speed to use
within this range.
boost state support:
Supported: no
Active: no
25500 MHz max turbo 4 active cores
25500 MHz max turbo 3 active cores
25500 MHz max turbo 2 active cores
25500 MHz max turbo 1 active cores

# zcat /proc/config.gz |grep PSTATE
CONFIG_X86_INTEL_PSTATE=y
Comment by Yangtse Su (yangtsesu) - Sunday, 05 May 2013, 10:04 GMT Comment by Yangtse Su (yangtsesu) - Sunday, 05 May 2013, 11:06 GMT
INTEL_PSTATE only works with intel snb chipsets.
Comment by Tobias Powalowski (tpowa) - Monday, 06 May 2013, 06:24 GMT
You own a SNB chipset?
Comment by Jan de Groot (JGC) - Monday, 06 May 2013, 07:35 GMT
Your CPU is claimed by the intel_pstate driver because your CPU supports it. That's why acpi-cpufreq can't load anymore. Also, this pstate driver is incompatible with most of cpufreq, which means you can only set performance or powersave governor. More about this is discussed here:
https://bugzilla.kernel.org/show_bug.cgi?id=57141

If you want acpi-cpufreq+ondemand, you should add intel_pstate=disable to the kernel bootup line.

Loading...