Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#35084 - [pacman] - makepkg does not auto unzip source file in lrzip format

Attached to Project: Pacman
Opened by John (graysky) - Friday, 03 May 2013, 19:18 GMT
Last edited by Dan McGee (toofishes) - Saturday, 04 May 2013, 17:56 GMT
Task Type Bug Report
Category makepkg
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.1.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Makepkg does not decompress a source file if that source is foo.lrz.

Steps to Reproduce:
1) Run `makepkg -s` on the attached PKGBUILD.
2) When makepkg finishes, `ls src` to find the compressed archive only.

Expected result: patch-3.9-ck1.lrz should be unzipped in $srcdir.
   PKGBUILD (0.2 KiB)
This task depends upon

Closed by  Dan McGee (toofishes)
Saturday, 04 May 2013, 17:56 GMT
Reason for closing:  Won't implement
Comment by Dave Reisner (falconindy) - Friday, 03 May 2013, 19:32 GMT
Needs special casing in extract_file since it isn't an archive: https://projects.archlinux.org/pacman.git/tree/scripts/makepkg.sh.in#n384

Notice that we don't handle other uncommon formats like zip, rar, or 7z, either.
Comment by John (graysky) - Friday, 03 May 2013, 19:50 GMT
Tks for the quick reply. Is the attached the recommended workaround?
   PKGBUILD (0.3 KiB)
Comment by Dave Reisner (falconindy) - Friday, 03 May 2013, 19:56 GMT
Sure. Unclear why you want to hide output, though.
Comment by John (graysky) - Friday, 03 May 2013, 20:35 GMT
Perfect thanks. Piped it to /dev/null to keep things quiet since lrzip doesn't have a -q switch and want the makepkg run to look like it does when it extracts any other source (i.e. no output). I will request the closing of the bug report.

Loading...