Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#35076 - [texlive-core][texlive-bin] lualatex PANIC with zlib 1.2.8

Attached to Project: Arch Linux
Opened by i magnific0 (magnific0) - Friday, 03 May 2013, 11:08 GMT
Last edited by Rémy Oudompheng (remyoudompheng) - Wednesday, 08 May 2013, 06:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Rémy Oudompheng (remyoudompheng)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 11
Private No


Upgrading zlib to 1.2.8 breaks lualatex. Exits with:
PANIC: unprotected error in call to Lua API (zlib library version does not match - header: 1.2.7, library: 1.2.8)

Additional info:
local/zlib 1.2.8-1
local/texlive-bin 2012.0-10
local/texlive-core 2012.29661-1
This task depends upon

Closed by  Rémy Oudompheng (remyoudompheng)
Wednesday, 08 May 2013, 06:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  fixed by texlive-bin 2012.0-11 (rebuild)

Comment by Paolo (palmaway) - Friday, 03 May 2013, 14:49 GMT
Confirmed: same problem here.
Comment by MadCatX (MadCatX) - Friday, 03 May 2013, 15:18 GMT
Same here, simple rebuild against the new zlib fixes the problem for me.
Comment by Rémy Oudompheng (remyoudompheng) - Friday, 03 May 2013, 18:09 GMT
Please try version 2012.0-11
Comment by François (Spip) - Sunday, 05 May 2013, 11:45 GMT
First try with texlive-bin 2012.0-11
texlua: error while loading shared libraries: cannot open shared object file: No such file or directory

Then, I installed texlive-bin 2012.0-11 + libpng from testing 1.6.2-2

I got this :
texlua: error while loading shared libraries: cannot open shared object file: No such file or directory
The same for lualatex.
Comment by Rémy Oudompheng (remyoudompheng) - Sunday, 05 May 2013, 18:36 GMT
I cannot reproduce this problem.
Comment by Clemens Buchacher (drizzd) - Sunday, 05 May 2013, 20:45 GMT
I can:

$ tar xJf texlive-bin-2012.0-11-i686.pkg.tar.xz usr/bin/luatex
$ ldd usr/bin/luatex (0xf7702000) => not found => not found

Libpng 1.6 is in testing. I don't know how this works, but I venture that one is not supposed to install individual packages from testing without enabling the repo entirely.
Comment by François (Spip) - Tuesday, 07 May 2013, 19:16 GMT
I just upgraded. It works for me. Thank you Rémy.
Comment by Anonymous (reallybmn) - Wednesday, 08 May 2013, 00:47 GMT
Also solved for me.
Comment by i magnific0 (magnific0) - Wednesday, 08 May 2013, 05:09 GMT
This has indeed fixed the problem, thanks.