Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35039 - [fontconfig] non-double matrix element in 10-scale-bitmap-fonts.conf

Attached to Project: Arch Linux
Opened by oblique (oblique) - Tuesday, 30 April 2013, 16:30 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 08 October 2013, 07:29 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 8
Private No

Details

Description:
I got the following errors:
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number

Additional info:
* package version(s): 2.10.92-4


In my case I reproduce it with:
HandBrakeCLI -i input.mkv -s 1 --subtitle-burned 1 --preset=Normal -o output.mp4

I'm sure there are many ways but I can't think another one for now.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 08 October 2013, 07:29 GMT
Reason for closing:  Not a bug
Additional comments about closing:  As upstream says in bugreport: this is not a problem with fontconfig or its configuration, but (non-free, unfixable) software that links static to older versions of fontconfig.
Comment by Paul Bredbury (brebs) - Tuesday, 30 April 2013, 17:56 GMT
That 10-scale-bitmap-fonts.conf is very strange - fontconfig itself moans about it, and who would even want it?

I simply don't install it:

sed -e "/10-scale-bitmap-fonts/d" -i conf.d/Makefile*

This bug is similar to  FS#34918 
Comment by David Bourgeois (dbourgeo) - Tuesday, 11 June 2013, 20:06 GMT
I have the exact same error messages for extra/fontconfig 2.10.93-1 [installed].
When I try to start skype-4.2.0.11-1-x86_64 I get that message and then skype dies after a couple of seconds.
Is there a way to remove these fonts without playing with the source?
Comment by Félix Delval (felix123) - Monday, 17 June 2013, 10:52 GMT
I have the same message with princexml 8.1 rev4.
Comment by Jon Watte (jwatte) - Sunday, 23 June 2013, 16:57 GMT
I get the same errors from trying to start native Steam.
The final section in that 10-scale-bitmap-fonts.conf looks invalid.
There's a section that defines "name" and "double" twice (before line 70) and another section that tries to divide by zero (before line 78) by using a "name" tag twice as a symbolic reference and a name. I don't understand how that's supposed to work at all.
Comment by Andreas Radke (AndyRTR) - Sunday, 07 July 2013, 10:33 GMT
This sounds like a misconfigured upstream file. Can you bring it upstream please?
Comment by Jon Watte (jwatte) - Sunday, 07 July 2013, 19:57 GMT
First, who is "You"? Paul, who reported this three months ago?
I think those well versed in Arch maintenance are much better suited to actually push the request upstream. Personally, I wouldn't know how to make this determination, and where to go for "upstream" reports.
Also, it would be useful if Arch removed the offending file in its own repository until a fix might come from upstream.
Comment by Thomas Kowaliczek (LinuxDonald) - Monday, 07 October 2013, 22:26 GMT

Loading...