Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35017 - [gnome-keyring] [gcr] have runtime dep on gtk3 when they aren't

Attached to Project: Arch Linux
Opened by dodo (dodo3773) - Sunday, 28 April 2013, 20:00 GMT
Last edited by Jan Steffens (heftig) - Saturday, 04 May 2013, 08:12 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
"gnome-keyring" and "gcr" have runtime dependency of "gtk3" it isn't a runtime dependency unless you want to use the included applications at "/usr/bin/gcr-viewer" and "/usr/bin/gnome-keyring" / "/usr/bin/gnome-keyring-3". It is a build dependency and an optional dependency if you wish to use the included gtk3 gui. Not needed for the functionality of the program gnome-keyring daemon to function.

Additional info:
* package version(s)
extra/gnome-keyring 3.8.1-1
extra/gcr 3.8.1-1

* config and/or log files etc.
N/A

Steps to reproduce:

Install packages and force remove gtk3 or edit the PKGBUILD and rebuild from abs changing runtime dep to build+optional dep and recompile. Everything still works for basic functionality of keyring as far as I can see.
This task depends upon

Closed by  Jan Steffens (heftig)
Saturday, 04 May 2013, 08:12 GMT
Reason for closing:  Not a bug
Comment by Jan Steffens (heftig) - Saturday, 04 May 2013, 08:12 GMT
It's needed during operation when prompting the user about untrusted keys or certificates.

Loading...