Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#35007 - [linux] 3.8.10 - 3.11.x ext4_da_write_pages: jbd2_start err -30

Attached to Project: Arch Linux
Opened by c (c) - Sunday, 28 April 2013, 07:51 GMT
Last edited by Tobias Powalowski (tpowa) - Sunday, 22 September 2013, 16:39 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Tobias Powalowski (tpowa)
Thomas B├Ąchler (brain0)
Architecture i686
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Since approximately two weeks either a systemd or kernel update may have started causing the below ext4 error on shutdown. It happens sporadically and one reference on the web says this is caused by a short block device timeout. The error is for dm-0 so there's no /sys/block/dm-0/device/timeout but just for the underlying disk at /sys/block/sda/device/timeout.

EXT4-fs error (dm-0): ext4_da_writepages: jdb2_start: 8192 pages, ino
30146867; err -30

Additional info:
* linux 3.8.10
* systemd 202-2


Steps to reproduce:
Shutdown without powering off but remember it's sporadic.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Sunday, 22 September 2013, 16:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  3.11.1
Comment by Tobias Powalowski (tpowa) - Monday, 06 May 2013, 12:35 GMT Comment by Tobias Powalowski (tpowa) - Wednesday, 08 May 2013, 09:47 GMT
Should be fixed with 3.9.1-1
Comment by c (c) - Wednesday, 08 May 2013, 19:23 GMT
Updated to 3.9.1-1 and saw the same error on 2nd shutdown (without poweroff to be sure).
Comment by ozar (ozar) - Monday, 13 May 2013, 21:16 GMT
Just noticed that I've started getting same error at shutdown but with 3.9.2 whereas I've not had this error previously.
Comment by Alex (__AlexL__) - Wednesday, 05 June 2013, 16:54 GMT
I have kernel 3.9.4. I've started getting same error at shutdown.
Comment by c (c) - Tuesday, 23 July 2013, 07:16 GMT
Same error with 3.10.2-1
Comment by c (c) - Tuesday, 30 July 2013, 13:21 GMT
Is it possible that recent updates or fixes in systemd have fixed the block device timeout issue? I haven't seen this or the usual systemd errors about failing to connect to some udev thing for at least week. I still see a single message on shutdown about some drives not being finalized or something like that. If that is the case and it was fixed by a different shutdown delay then I'm wondering how that can happen at all and if it's not the kernel's ultimate job to shutdown properly and not be too fast.
Comment by Bug Reporter 35296 (TtTFQN) - Friday, 30 August 2013, 18:21 GMT
still present with 3.10.9-1
Comment by Tobias Powalowski (tpowa) - Tuesday, 17 September 2013, 09:57 GMT
Status on 3.11.1?
Comment by c (c) - Wednesday, 18 September 2013, 20:50 GMT
At least I haven't seen this since a systemd update in July (comment above) and believe this was caused by systemd.

Shouldn't the kernel have the last say and not be overridable from userspace for the underlying disk's device timeout?
Comment by Alex (__AlexL__) - Thursday, 19 September 2013, 05:18 GMT
I see this error almost all time. I think systemd is not the cause.
Comment by Alex (__AlexL__) - Sunday, 22 September 2013, 11:53 GMT
I didn't see this error after latest systemd update. So may be in fact the systemd was the cause.
Comment by ozar (ozar) - Sunday, 22 September 2013, 12:32 GMT
Good day, tpowa... just wanted to reply as per your status update request to say that I'm no longer seeing this error message.

Loading...