Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34992 - [gcc{,-multilib}] gcc 4.8 incorrectly compiles a series of memcpy

Attached to Project: Arch Linux
Opened by Emil (xexaxo) - Saturday, 27 April 2013, 16:00 GMT
Last edited by Allan McRae (Allan) - Sunday, 28 April 2013, 10:02 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Allan McRae (Allan)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Whenever program uses two consecutive memcpy, gcc incorrectly optimizes the function and "corrupts" the dest pointer. The bug was unveiled via wine, although it may cause issues with other apps


Additional info:
* package version(s) - gcc{,-multilib} 4.8.0-2


Steps to reproduce:
1. Compile the test program [1] and execute

or
1. Install multilib wine 1.5.28-1, and run any program
Note: The wine package (as of 1.5.28-2) has a workaround for the issue


Solution:
Rebuild gcc with the fix [2]

Note: The issue is present on x86-64 systems, although the patch is save to apply for both i686 and x86-64


[1] http://gcc.gnu.org/bugzilla/show_bug.cgi?id=57003#c17
[2] http://gcc.gnu.org/viewcvs?rev=198321&root=gcc&view=rev
This task depends upon

Closed by  Allan McRae (Allan)
Sunday, 28 April 2013, 10:02 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.8.0-3 in [testing]

Loading...