Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34987 - [libsoup] Unable to log in via gdm (2.42.2-1)

Attached to Project: Arch Linux
Opened by C. L. Charles (Chowchilla) - Saturday, 27 April 2013, 13:59 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 July 2013, 08:21 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:

Upgraded from Gnome 3.6 -> 3.8 without issue.

Later upgraded libsoup 2.42.1-1 -> 2.42.2-1.

Upon restart was unable to log in via gdm.

First time was able to reach gdm screen and enter login details, but did not reach Gnome desktop, only gdm background and cursor visible.

Second and third times did not even reach gdm screen, screen remained on plymouth.

Downgraded to libsoup 2.42.1-1.

Restarted and issue disappeared.


Additional info:
* package version = 2.42.2-1


Steps to reproduce:

- Upgrade to libsoup 2.42.2-1 on a Gnome 3.8 install (may not apply to a fresh install, only an upgrade from 3.6).

- Restart and try to login via gdm.

- Downgrade to 2.42.1-1 and see if issue resolved.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 July 2013, 08:21 GMT
Reason for closing:  Works for me
Additional comments about closing:  There have been several bugfixes for issues reported here:
- locale-dependent problems: fixed with webkitgtk3 update
- freeze after login: fixed with gnome-settings-daemon update
Comment by Jan Steffens (heftig) - Saturday, 27 April 2013, 19:07 GMT
Can't reproduce.
Comment by Nate G. (nateg3.14159) - Sunday, 28 April 2013, 18:35 GMT
Confirming both the bug and that downgrading libsoup fixes the problem.
Also, I found that moving my .config/dconf folder followed by running systemctl restart gdm would allow me to login once, but i would have to repeat the process every time i restart.
Comment by Ionut Biru (wonder) - Sunday, 28 April 2013, 18:44 GMT
cannot reproduce it.
Comment by lkoos (lkoos) - Monday, 29 April 2013, 09:59 GMT
I have the same problem. I wonder if it's related to the glib2-2.36 problems discussed here https://bugs.archlinux.org/task/34980, here https://bugs.archlinux.org/task/34892 and here https://bugs.archlinux.org/task/34936.
Comment by C. L. Charles (Chowchilla) - Tuesday, 07 May 2013, 12:31 GMT
Turns out this may be due to locale. Try changing to another and see if issue resolved. If so, should then be able to switch back to original. See https://bbs.archlinux.org/viewtopic.php?id=162232

Loading...