Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34972 - [nginx] Passenger is broken

Attached to Project: Community Packages
Opened by Paul Gideon Dann (giddie) - Friday, 26 April 2013, 13:06 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Friday, 17 May 2013, 06:37 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

When attempting to run nginx with Passenger configured, Passenger fails to start. This is serious! Log is pasted below. I've reproduced this on two systems. (Sadly the first one was a production server; I'd failed to restart nginx after the previous upgrade, and it took me *ages* to think of downgrading nginx by *two* versions! <cringe/>)

Additional info:
* The last version that I know works is 1.2.7-5. I know that 1.2.8-1 and 1.4.0-2 are broken.
* Using Passenger 3.0.19.

I'm aware this may well be an upstream issue, but it could also be a configuration or packaging issue, and I wanted to post it here in case the packager is aware of having changed something that might have caused the issue.

Log:
terminate called after throwing an instance of 'Passenger::VariantMap::MissingKeyException'
what(): Required key 'ruby' is missing
[ pid=3158, timestamp=1366980777 ] Process aborted! signo=SIGABRT(6), reason=SI_TKILL, signal sent by PID 3158 with UID 0, backtrace available.
--------------------------------------
[ pid=3158 ] Backtrace with 12 frames:
PassengerWatchdog[0x481170]
/usr/lib/libpthread.so.0(+0xf0e0)[0x7f19c49b00e0]
/usr/lib/libc.so.6(gsignal+0x39)[0x7f19c3e111c9]
/usr/lib/libc.so.6(abort+0x148)[0x7f19c3e125c8]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x155)[0x7f19c46fd935]
/usr/lib/libstdc++.so.6(+0x5eaa6)[0x7f19c46fbaa6]
/usr/lib/libstdc++.so.6(+0x5ead3)[0x7f19c46fbad3]
/usr/lib/libstdc++.so.6(+0x5ecfe)[0x7f19c46fbcfe]
PassengerWatchdog(_ZNK9Passenger10VariantMap3getERKSsb+0x8a)[0x4593e6]
PassengerWatchdog(main+0x4ac)[0x452e11]
/usr/lib/libc.so.6(__libc_start_main+0xf5)[0x7f19c3dfda15]
PassengerWatchdog[0x450c39]
--------------------------------------
[ pid=3158 ] Dumping a more detailed backtrace with crash-watch ('gem install crash-watch' if you don't have it)...
sh: crash-watch: command not found
2013/04/26 13:52:57 [alert] 3157#0: Unable to start the Phusion Passenger watchdog: it seems to have crashed during startup for an unknown reason, with exit code 1 (-1: Unknown error)
terminate called after throwing an instance of 'Passenger::VariantMap::MissingKeyException'
what(): Required key 'ruby' is missing
[ pid=3165, timestamp=1366980777 ] Process aborted! signo=SIGABRT(6), reason=SI_TKILL, signal sent by PID 3165 with UID 0, backtrace available.
--------------------------------------
[ pid=3165 ] Backtrace with 12 frames:
PassengerWatchdog[0x481170]
/usr/lib/libpthread.so.0(+0xf0e0)[0x7f52196350e0]
/usr/lib/libc.so.6(gsignal+0x39)[0x7f5218a961c9]
/usr/lib/libc.so.6(abort+0x148)[0x7f5218a975c8]
/usr/lib/libstdc++.so.6(_ZN9__gnu_cxx27__verbose_terminate_handlerEv+0x155)[0x7f5219382935]
/usr/lib/libstdc++.so.6(+0x5eaa6)[0x7f5219380aa6]
/usr/lib/libstdc++.so.6(+0x5ead3)[0x7f5219380ad3]
/usr/lib/libstdc++.so.6(+0x5ecfe)[0x7f5219380cfe]
PassengerWatchdog(_ZNK9Passenger10VariantMap3getERKSsb+0x8a)[0x4593e6]
PassengerWatchdog(main+0x4ac)[0x452e11]
/usr/lib/libc.so.6(__libc_start_main+0xf5)[0x7f5218a82a15]
PassengerWatchdog[0x450c39]
--------------------------------------
[ pid=3165 ] Dumping a more detailed backtrace with crash-watch ('gem install crash-watch' if you don't have it)...
sh: crash-watch: command not found
2013/04/26 13:52:57 [alert] 3164#0: Unable to start the Phusion Passenger watchdog: it seems to have crashed during startup for an unknown reason, with exit code 1 (-1: Unknown error)
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Friday, 17 May 2013, 06:37 GMT
Reason for closing:  Fixed
Additional comments about closing:  nginx 1.4.1-3
Comment by Paul Gideon Dann (giddie) - Wednesday, 08 May 2013, 11:05 GMT
I reckon this is a binary-compatibility issue. It seems that the nginx package is compiled against a pre-release of the next version of the passenger gem (4.0.0.rc6-2), which is available in [community]. Since I use rubygems for all gem management (instead of pacman), I'm not using this pre-release, and they're presumably not compatible. The simple fix is to just recompile nginx against the installed passenger gem.

Loading...