Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34905 - gnome-settings-daemon 3.8.1-1: volume keys NOT working

Attached to Project: Arch Linux
Opened by Federico Colnago (curson) - Tuesday, 23 April 2013, 08:17 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 April 2013, 09:43 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: as of after the upgrade to Gnome 3.8 (and concurrently to gnome-settings-daemon 3.8.1-1) the volume media keys (for me, on my Dell XPS 14z, FN+F7,8,9) don't work anymore. I use openbox, and leave its ~/.config/openbox/autostart.sh to handle the launching of gnome-settings-daemon. Similar media keys for the control of playing (like reverse, forward, and pause) still work perfectly. In Gnome-Control-Center->Keyboard->Shortcut I can clearly see the three keys for Mute,VolumeUP,VolumeDOWN being recognized.


Additional info:
Starting gnome-setting-daemon gives me this warnings, even though it seems to launch correctly (and it changes, for example, the default text style to the one I specified for me GTK application, which I take as a sign of it starting regardless of the warnings...):

$> /usr/lib/gnome-settings-daemon/gnome-settings-daemon

(gnome-settings-daemon:6732): power-plugin-WARNING **: failed to turn the panel on: Could not change DPMS mode

** (gnome-settings-daemon:6732): WARNING **: Unable to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files

** (process:6737): WARNING **: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files


Steps to reproduce: upgrade to package version 3.8.1-1. Trying a downgrade via 'pacman -U' and a previously downloaded version of the package (3.6.4-2, for example) doesn't work, I believe due to incompatibility with the newer Gnome environment. Somebody else seems to be experiencing the same issue as well on different hardware: https://bbs.archlinux.org/viewtopic.php?pid=1262375
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 April 2013, 09:43 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Upstream doesn't support standalone components. It's all or nothing.
Comment by Jan de Groot (JGC) - Tuesday, 23 April 2013, 09:30 GMT
Upstream doesn't support this anymore. gnome-settings-daemon needs gnome-shell for media keys:

==============
Version 3.7.92
==============

Media keys:
- Remove obsolete check for XInput2
- Use the shell's D-Bus interface to show OSDs
- Fix warnings on startup trying to call gnome-shell


==============
Version 3.7.91
==============

Media keys:
- Key grabbing is now done in gnome-shell, which fixes problems
with keybindings not working in certain conditions
Comment by Federico Colnago (curson) - Tuesday, 23 April 2013, 09:33 GMT
So the fact that there is no media keys working in an environment like mine with Openbox and no gnome-shell running *is* the actual intended behaviour.

Can't say I'm pleased, but thanks for clearing that up. I'll look into alternatives to get those media-keys working again without the help of 'gnome-settings-daemon' then.

Loading...