Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34903 - [kdesdk-poxml] move antlr2 to optdepends

Attached to Project: Arch Linux
Opened by Wilco (Wilco) - Tuesday, 23 April 2013, 07:21 GMT
Last edited by Andrea Scarpino (BaSh) - Wednesday, 08 May 2013, 06:58 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andrea Scarpino (BaSh)
Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
kdesdk-poxml is the only kde package that depends on java. Kdesdk-poxml is not normally needed by desktop users and maybe should be removed from the meta package kde-meta-kdesdk to prevent installation of all the java dependencies when a user installs kde-meta.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
pacman -S kde-meta
This task depends upon

Closed by  Andrea Scarpino (BaSh)
Wednesday, 08 May 2013, 06:58 GMT
Reason for closing:  Implemented
Additional comments about closing:  kdesdk-poxml 4.10.3-1
Comment by Andrea Scarpino (BaSh) - Wednesday, 24 April 2013, 19:44 GMT
Implemented on trunk.
Comment by Sven-Hendrik Haase (Svenstaro) - Friday, 26 April 2013, 00:24 GMT
Well then, can't this be closed?
Comment by Andrea Scarpino (BaSh) - Friday, 26 April 2013, 07:31 GMT
This will be fixed in 4.10.3-1 (or before if we rebuild kdesdk for some reason), so keep it open until then.

Loading...