Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34901 - [gnome-shell][gdm] No visible mouse pointer in gdm/gnome shell

Attached to Project: Arch Linux
Opened by Michael Wilson (meowfaceman) - Tuesday, 23 April 2013, 05:22 GMT
Last edited by Jan Alexander Steffens (heftig) - Friday, 07 February 2014, 05:55 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Ionut Biru (wonder)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description: When using gdm or gnome shell, no mouse pointer is visible. The mouse pointer is active and functional, but there is no visual representation.

Disabling the HWCursor does not solve the issue. The mouse pointer is visible using lightdm and Xfce. If I select the Gnome desktop from lightdm, the mouse pointer disappears. If I select Xfce from gdm, the mouse pointer appears. Basically, as soon as anything Gnome desktop related enters the equation, it looks like the mouse pointer disappears, and when Gnome leaves, it reappears. If I enable zoom in Gnome, the mouse is visible. Other than that, there does not appear to be any way to induce the mouse pointer to become visible in any way.

Additional info:
* gnome-shell 3.8.1-1
* gdm 3.8.1.1-1
* Running a Radeon HD 5450 using open source ATI/Radeon drivers
* Xorg 1.14.0
* Kernel 3.8.8
* synergy 1.4.10-2


Steps to reproduce:
Run gdm or Gnome. The mouse is not visible.
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Friday, 07 February 2014, 05:55 GMT
Reason for closing:  Won't fix
Comment by Michael Wilson (meowfaceman) - Tuesday, 23 April 2013, 05:26 GMT
Sorry, to be clear: Xorg-server 1.14.1-1
Comment by Matthias Dienstbier (fs4000) - Tuesday, 23 April 2013, 09:28 GMT
Gnome hides the mouse cursor at startup probably in favor of touch devices. The cursor reappears when you move the mouse.
I think the problem comes with synergy. You should report this in the Gnome bug tracker as the Arch Linux devs won't be able to do anything for you. The relevant product should be Core/gnome-settings-daemon.

https://bugzilla.gnome.org/
Comment by Jan de Groot (JGC) - Tuesday, 23 April 2013, 09:35 GMT
I face this bug in a gnome setup without synergy now and then, but so far I haven't found a reliable way to reproduce it.
Comment by Michael Wilson (meowfaceman) - Wednesday, 24 April 2013, 03:28 GMT
I was able to alleviate this issue by attaching a mouse to my Linux machine -- it does nothing except sit there and be pretty, basically. Regardless, Matthias, this seems to confirm your suspicion that this is not an Arch bug.
Comment by Manuel Bua (manuel) - Friday, 23 August 2013, 08:59 GMT
I've the same problem on my desktop, Gnome Shell + nVidia blob, no synergy: i've been able to reproduce it consistently by starting moving the mouse *before* the shell is hiding it, at this point the cursor hides and will never be visible again, until one logout and login again.
Comment by x0b1t (x0b1t) - Wednesday, 02 October 2013, 20:46 GMT
i have solution for issue.
just unset setting /org/gnome/settings-daemon/plugins/cursor/active (set to FALSE), f.e.:
dconf write /org/gnome/settings-daemon/plugins/cursor/active false
Comment by Jan Alexander Steffens (heftig) - Friday, 07 February 2014, 05:55 GMT
GNOME hides the pointer for touch. Either convince GNOME that the Synergy pointer emulation is not a touch device, or deactivate the cursor handling as above.

A related bug ( FS#37416 ) sometimes prevented the cursor from reappearing when switching devices, but that should be fixed now.

Loading...