Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34893 - [gdm] 3.8.1 Fails to Start Gnome Shell

Attached to Project: Arch Linux
Opened by Sudhir Khanger (donniezazen) - Monday, 22 April 2013, 21:13 GMT
Last edited by Jan de Groot (JGC) - Tuesday, 23 July 2013, 08:32 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 10
Private No

Details

Description:
On a clean install of Arch Linux with Gnome 3.8.1, GDM fails to boot to desktop.

Additional info:
* package version(s)
GDM 3.8.1.1-1

* config and/or log files etc.
Please see Xorg.0.log and a picture of startx output.


Steps to reproduce:
Install or upgrade to GDM 3.8.1

Please let me know what more information is required. Thanks.
This task depends upon

Closed by  Jan de Groot (JGC)
Tuesday, 23 July 2013, 08:32 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in recent mesa versions.
Comment by Sudhir Khanger (donniezazen) - Monday, 22 April 2013, 21:15 GMT
Here is the startx output picture http://imgur.com/yxe82kW
Comment by Daniele (Taylor001) - Monday, 22 April 2013, 22:11 GMT
Confirmed.
Can start gnome only with lightdm and downgrading gnome-session to 3.6.2-1.
Comment by Manuel Montoya (aarkerio) - Monday, 22 April 2013, 22:49 GMT
GDM and gnome-session not working after upgrade to 3.8.

I uninstalled GDM. When I tried:

$startx /usr/bin/gnome-session

I get:

Received signal:1->'Hangup'
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.

Received signal:15->'Terminated'

OK


When I tried:

$startx /usr/bin/lxsession

Everything works fine. I am using catalyst-dkms proprietary driver and works fine on LXDE.

The french guys in Gentoo have the same issue:

http://forums.gentoo.org/viewtopic-t-954586.html?sid=3c41f34fb2bc2219d2aa21178cc8f87c
Comment by Sudhir Khanger (donniezazen) - Tuesday, 23 April 2013, 15:32 GMT Comment by Daniele (Taylor001) - Tuesday, 23 April 2013, 16:48 GMT
I'm not using Intel graphics of any kind.
I'm using gnome-flashback-session.

gnome-session 3.8.1-1 always displays "On no, something has gone wrong." no matter what login manager I choose.
The only way to log into gnome is by using gnome-session 3.6.2.

gnome-shell session works.
Comment by Manuel Montoya (aarkerio) - Tuesday, 23 April 2013, 17:49 GMT
The whole messages I am getting are:

$ gnome-session
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Ww2Cft
SSH_AUTH_SOCK=/run/user/1000/keyring-Ww2Cft/ssh
GNOME_KEYRING_PID=7316
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Ww2Cft
SSH_AUTH_SOCK=/run/user/1000/keyring-Ww2Cft/ssh
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Ww2Cft
SSH_AUTH_SOCK=/run/user/1000/keyring-Ww2Cft/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-Ww2Cft/gpg:0:1
GNOME_KEYRING_CONTROL=/run/user/1000/keyring-Ww2Cft
SSH_AUTH_SOCK=/run/user/1000/keyring-Ww2Cft/ssh
GPG_AGENT_INFO=/run/user/1000/keyring-Ww2Cft/gpg:0:1

(gnome-settings-daemon:7304): color-plugin-WARNING **: failed to get edid: unable to get EDID for output

(gnome-settings-daemon:7304): color-plugin-WARNING **: unable to get EDID for xrandr-LVDS: unable to get EDID for output
Window manager warning: Screen 0 on display ":0.0" already has a window manager
Window manager warning: Screen 0 on display ":0.0" already has a window manager
gnome-session[7297]: WARNING: App 'gnome-shell.desktop' respawning too quickly

(gnome-settings-daemon:7304): GLib-CRITICAL **: g_variant_builder_end: assertion `!GVSB(builder)->uniform_item_types || GVSB(builder)->prev_item_type != NULL || g_variant_type_is_definite (GVSB(builder)->type)' failed

(gnome-settings-daemon:7304): GLib-CRITICAL **: g_variant_get_type: assertion `value != NULL' failed

(gnome-settings-daemon:7304): GLib-CRITICAL **: g_variant_type_is_subtype_of: assertion `g_variant_type_check (type)' failed

(gnome-settings-daemon:7304): GLib-CRITICAL **: g_variant_get_type_string: assertion `value != NULL' failed

(gnome-settings-daemon:7304): GLib-ERROR **: g_variant_new: expected GVariant of type `a(su)' but received value has type `(null)'
gnome-session[7297]: WARNING: Application 'gnome-settings-daemon.desktop' killed by signal 5
Importing pynotify failed, notifications disabled.
Has notifications support False
Loading...
Connecting to daemon...
Connected.
displaytray True
Done loading.
Failed to play sound: File or data not found

** (nm-applet:7450): WARNING **: Could not initialize NMClient /org/freedesktop/NetworkManager: Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.
** Message: applet now removed from the notification area

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'
** Message: applet now embedded in the notification area
** Message: applet now removed from the notification area

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

** (nm-applet:7450): WARNING **: fetch_connections_done: error fetching connections: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details..

** (nm-applet:7450): WARNING **: Failed to register as an agent: (32) Unit dbus-org.freedesktop.NetworkManager.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.NetworkManager.service' for details.

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): GLib-CRITICAL **: g_variant_get_boolean: assertion `g_variant_is_of_type (value, G_VARIANT_TYPE_BOOLEAN)' failed

(gnome-settings-daemon:7461): keyboard-plugin-WARNING **: Unhandled settings change, key 'bell-custom-file'

(gnome-settings-daemon:7461): color-plugin-WARNING **: failed to get edid: unable to get EDID for output

(gnome-settings-daemon:7461): color-plugin-WARNING **: unable to get EDID for xrandr-LVDS: unable to get EDID for output

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed

(gnome-settings-daemon:7461): wacom-plugin-CRITICAL **: gsd_wacom_device_get_device_type: assertion `GSD_IS_WACOM_DEVICE (device)' failed
[aarkerio@xps scripts]$
Comment by Luis Henrique Mello (lmello) - Friday, 26 April 2013, 20:17 GMT
New libsoup is available, disable gdm.service, upgrade libsoup FIRST, then upgrade the kernel, then reboot, then upgrade the rest, then enable gdm.service. These were the steps I made to make 3.8 work, maybe they'll work out for more people.

Loading...