Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34871 - [gimp] Does not start & Dependency error

Attached to Project: Arch Linux
Opened by Hong Shick Pak (hspasta) - Sunday, 21 April 2013, 21:39 GMT
Last edited by Isenmann Daniel (ise) - Tuesday, 31 December 2013, 11:49 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Isenmann Daniel (ise)
Architecture x86_64
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: gimp will not start. There is no output whatsoever.

Without openexr, I get these errors when I try to run gimp:
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-load.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or directory
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-save.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or director

With openexr, I get no output even with gimp --verbose. It just hangs.

Additional info:
gimp 2.8.4-1
gegl 0.2.0-7

Steps to reproduce:
run gimp
This task depends upon

Closed by  Isenmann Daniel (ise)
Tuesday, 31 December 2013, 11:49 GMT
Reason for closing:  Fixed
Additional comments about closing:  openexr will be added as dependency in the next update.

Packages are building right now.
Comment by Stefan Schindler (TankBo) - Monday, 22 April 2013, 15:13 GMT
I can confirm this bug. I upgraded to version 2.8.4-1. The splash screen shows up and loads extensions, followed by the main window. However the window keeps gray and freezes.

When I rename ~/.gimp-2.8 to something else, GIMP doesn't start at all (no messages with --verbose neither).
Comment by Stefan Schindler (TankBo) - Monday, 22 April 2013, 16:03 GMT
Downgrading back to glib2-2.34.3-1 fixes this. So I assume that the GIMP package itself is sane.
Comment by Jelle van der Waa (jelly) - Tuesday, 23 April 2013, 11:32 GMT
Works fine for me with the latest glib2. openexr is probably and optdependency.
Comment by Stefan Schindler (TankBo) - Tuesday, 23 April 2013, 11:35 GMT
@jelly: Did you do a full system upgrade?
Comment by Hong Shick Pak (hspasta) - Tuesday, 23 April 2013, 13:29 GMT
I just got glib2-2.36.1-2 and I still have the same issue as reported.
Comment by Jelle van der Waa (jelly) - Thursday, 25 April 2013, 08:21 GMT
Is there output in dmesg or journalctl ? Since it's hard to fix this issue without errors.

Tankbo, yes I'm up to date. What kind of hardware do you use?
Comment by Jan de Groot (JGC) - Thursday, 25 April 2013, 11:36 GMT
Please try glib2 2.36.1-3. A patch from upstream was added to fix hangs in applications like pidgin, probably also affects gimp: https://git.gnome.org/browse/glib/commit/?h=glib-2-36&id=f3b1054b0ebb4912f700e08da0c3d35c30113e79
Comment by Stefan Schindler (TankBo) - Thursday, 25 April 2013, 11:47 GMT
@JGC: Fixes it for me! Thanks a lot.
@jelly: I guess you won't need any more input from me. ;)
Comment by Hong Shick Pak (hspasta) - Thursday, 25 April 2013, 12:54 GMT
glib2 2.36.1-3 has fixed this problem. :)
Comment by Roel D (roelpaddestoel) - Sunday, 28 July 2013, 13:02 GMT
  • Field changed: Percent Complete (100% → 0%)
Gimp runs fine, but not in script mode (-i parameter = no-interface)
I use this to run some custom-made scripts, but these are not necessary to reproduce the problem:

$ gimp -i -b "(gimp-quit 0)"
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-save.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or directory
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-load.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or directory
$

The scripts run just fine in Gimp itself, but it would be nice if I could use them from the command-line again.

I am using gimp 2.8.6-1, gegl 0.2.0-8 and glib2 2.36.3-3
Comment by Robert Orzanna (orschiro) - Thursday, 14 November 2013, 15:11 GMT
I get the same error whenever I open an image file with GIMP:

$ gimp gimp2.png
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-save.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or directory
GEGL-geglmodule.c-Message: Module '/usr/lib/gegl-0.2/exr-load.so' load error: libIlmImf-Imf_2_0.so.20: cannot open shared object file: No such file or directory

~ $ l /usr/lib/gegl-0.2/exr-save.so
-rwxr-xr-x 1 root root 18904 2013-10-20 03:38:39.000000000 +0200 /usr/lib/gegl-0.2/exr-save.so

gimp 2.8.8-1, gegl 0.2.0-10, glib2 2.38.1-1, lib32-glib2 2.38.1-1
Comment by Robert Orzanna (orschiro) - Friday, 22 November 2013, 10:11 GMT
I could resolve the error by installing the packages `ilmbase` and `openexr`.
Comment by Roel D (roelpaddestoel) - Saturday, 23 November 2013, 07:57 GMT
@orschiro: Thanks, that works indeed.
Comment by Robert Orzanna (orschiro) - Saturday, 23 November 2013, 08:25 GMT
Should these packages maybe become a dependency of GIMP?

Loading...