Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34854 - [apache][systemd] httpd.service fails to start with systemd 202-1

Attached to Project: Arch Linux
Opened by Evangelos Foutras (foutrelis) - Friday, 19 April 2013, 14:19 GMT
Last edited by Evangelos Foutras (foutrelis) - Friday, 19 April 2013, 20:39 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After upgrading to systemd 202-1 httpd.service fails to start with the following error:

systemd[1]: Starting Apache Web Server...
apachectl[21956]: /usr/sbin/apachectl: line 84: 21958 Segmentation fault (core dumped) $HTTPD -k $ARGV
systemd-coredump[21959]: Process 21958 (httpd) dumped core.
systemd[1]: httpd.service: control process exited, code=exited status=139
systemd[1]: Failed to start Apache Web Server.
systemd[1]: MESSAGE=Unit httpd.service entered failed state.

dmesg further shows a segfault in libapr-1:

httpd[21958]: segfault at 1c ip 00007ff4b9e9e786 sp 00007ffffc7496b0 error 4 in libapr-1.so.0.4.6[7ff4b9e80000+2f000]

Downgrading to systemd 201-2 allows httpd.service to successfully start.


Package versions:

apache 2.2.24-1
systemd 202-1


Steps to reproduce:

Try to start Apache with 'systemctl start httpd'.
This task depends upon

Closed by  Evangelos Foutras (foutrelis)
Friday, 19 April 2013, 20:39 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 202-2
Comment by Evangelos Foutras (foutrelis) - Friday, 19 April 2013, 16:09 GMT
Did a Git bisection of systemd and the problematic commit appears to be:

1c6330456c5ae76085c63d2a7cf3d722596e545a is the first bad commit
commit 1c6330456c5ae76085c63d2a7cf3d722596e545a
Author: Zbigniew Jędrzejewski-Szmek <zbyszek@(redacted)>
Date: Fri Apr 5 22:24:10 2013 -0400

Use initalization instead of explicit zeroing in more places

:040000 040000 2428b07a0e0d0fe538024c3576f0bd94d2fdafd0 1f1a30c844563a57272bfd4331cf348b359a431f M src

http://cgit.freedesktop.org/systemd/systemd/commit/?id=1c6330456c5ae76085c63d2a7cf3d722596e545a
Comment by phanisvara das (phani00) - Friday, 19 April 2013, 16:54 GMT
strange, apache still works for me (same versions of systemd & apache):

[root@laptop phani]# systemctl status httpd
httpd.service - Apache Webserver
Loaded: loaded (/etc/systemd/system/httpd.service; disabled)
Active: active (running) since Fri 2013-04-19 22:18:07 IST; 5min ago
Process: 1014 ExecStart=/usr/sbin/httpd -k start $OPTIONS (code=exited, status=0/SUCCESS)
Main PID: 1015 (httpd)
CGroup: name=systemd:/system/httpd.service
├─1015 /usr/sbin/httpd -k start
├─1016 /usr/sbin/httpd -k start
├─1017 /usr/sbin/httpd -k start
├─1018 /usr/sbin/httpd -k start
├─1019 /usr/sbin/httpd -k start
├─1020 /usr/sbin/httpd -k start
└─1021 /usr/sbin/httpd -k start

Apr 19 22:18:06 laptop httpd[1014]: Warning: DocumentRoot [/home/phani/webapps/sym] does not exist
Apr 19 22:18:06 laptop httpd[1014]: Warning: DocumentRoot [/home/phani/webapps/tiki2] does not exist
Apr 19 22:18:07 laptop systemd[1]: Started Apache Webserver.


here's my system info, if that helps:

[phani@laptop ~]$ inxi -b
System: Host: laptop Kernel: 3.8.8-1-ARCH x86_64 (64 bit) Desktop: KDE 4.10.2 Distro: Arch Linux
Machine: Mobo: ASUSTeK model: K53SK version: 1.0 Bios: American Megatrends version: K53SK.203 date: 10/11/2011
CPU: Quad core Intel Core i7-2670QM CPU (-HT-MCP-) clocked at 800.00 MHz
Graphics: Card-1: Intel 2nd Generation Core Processor Family Integrated Graphics Controller
Card-2: Advanced Micro Devices [AMD] nee ATI Whistler LE [AMD Radeon HD 6625M Graphics]
X.Org: 1.14.1 driver: intel Resolution: 1366x768@60.0hz
GLX Renderer: Mesa DRI Intel Sandybridge Mobile GLX Version: 3.0 Mesa 9.1.1
Network: Card-1: Intel Centrino Wireless-N 100 driver: iwlwifi
Card-2: Realtek RTL8111/8168 PCI Express Gigabit Ethernet controller driver: r8168
Drives: HDD Total Size: 750.2GB (35.6% used)
Info: Processes: 230 Uptime: 6 min Memory: 1352.2/5876.4MB Client: Shell (bash) inxi: 1.8.45
Comment by Evangelos Foutras (foutrelis) - Friday, 19 April 2013, 17:15 GMT
After further investigation with Dave on IRC, the issue only occurs when /etc/hosts doesn't contain the computer's hostname and thus nss-myhostname is used.

Loading...