Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34841 - [systemd] fails to execute reboot or shutdown

Attached to Project: Arch Linux
Opened by Peter Weber (hoschi) - Thursday, 18 April 2013, 09:46 GMT
Last edited by Dave Reisner (falconindy) - Friday, 19 April 2013, 12:30 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Dave Reisner (falconindy)
Tom Gundersen (tomegun)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hello!

Commands like "systemctl reboot" or "systemctl halt" fails to execute.

Description:
systemd-198 included a new feature:
> Inhibitors are now honored and listed by "systemctl
> suspend", "systemctl poweroff" (and similar) too, not only
> GNOME. These commands will also list active sessions by
> other users.

The feature itself works. Sadly systemd doesn't clean up the files in the directory /run/systemd/sessions, after a user logged out from the session. This leads to the situation, that systemd believes a closed session stays in the condition of "closing" forever!

Additional info:
* package version(s): occurs since systemd-198, but foundation of the bug itself occurs at least since systemd-197
* an upstream patch is available: https://bugs.freedesktop.org/show_bug.cgi?id=62676
* users of tty, ssh or shell-scripts are affected
* (currently) desktop-environments or Ctrl+Alt+Delete are not affected (use other code to execute command)

Steps to reproduce:
1. user logs in
2. root logs in
3. root logs out
4. user executes "systemctl reboot"
5. reboot fails and complains about that root is still logged in

I suggested to add the upstream patch to systemd.
Rationale:
-> patch comes from upstream and is accepted
-> patch is small
-> bug breaks major features

Thanks!
This task depends upon

Closed by  Dave Reisner (falconindy)
Friday, 19 April 2013, 12:30 GMT
Reason for closing:  Fixed
Comment by Dave Reisner (falconindy) - Thursday, 18 April 2013, 17:45 GMT
...and if you look at the package, I already applied this patch to systemd-201-2.
Comment by Peter Weber (hoschi) - Friday, 19 April 2013, 07:33 GMT
Great! I didn't checked the package in the meantime!
Seems to be included in in systemd-202.

Loading...