Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#34776 - [python2-migrate] not compatible with python2-sqlalchemy

Attached to Project: Community Packages
Opened by xduugu (xduugu) - Sunday, 14 April 2013, 11:58 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 19 April 2013, 17:05 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
python2-migrate is not compatible with python2-sqlalchemy 0.8.x, but it can be fixed by changing one line so that at least pytrainer[1] runs again. The cause of this incompatibility is the following change in sqlalchemy:

[general] [removed] The “sqlalchemy.exceptions” synonym for “sqlalchemy.exc” is removed fully. [2]

A patch that can be applied in the PKGBUILD to fix the import is attached.

Additional info:
* python2-migrate 0.7.2-2
* python2-sqlalchemy 0.8.0-1

[1] https://aur.archlinux.org/packages/pytrainer/
[2] http://docs.sqlalchemy.org/en/latest/changelog/changelog_08.html#change-5cdfbadad1d1ab8b583def86bfe1c3b8
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 19 April 2013, 17:05 GMT
Reason for closing:  Fixed
Comment by Magnus Therning (magus) - Tuesday, 16 April 2013, 20:44 GMT
The same issue makes 'buildbot' broken. With the change proposed I at least manage to run 'buildbot create-master' successfully.

Loading...