Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#34775 - [qtchooser] qtconfig refers to wrong path

Attached to Project: Arch Linux
Opened by Marvin Gülker (Quintus) - Sunday, 14 April 2013, 08:50 GMT
Last edited by Andrea Scarpino (BaSh) - Tuesday, 16 April 2013, 22:26 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Andrea Scarpino (BaSh)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 6
Private No



/usr/bin/qtconfig doesn’t start because it tries to start /usr/lib/qt/bin/qtconfig, which doesn’t exist. This path should rather be /usr/lib/qt4/bin/qtconfig (note the 4):

% qtconfig
qtconfig: could not exec '/usr/lib/qt/bin/qtconfig': No such file or directory

Additional info:

qtconfig is in the qtchooser package, which I have in this version:

% LANG=en_US.utf8 pacman -Qi qtchooser
Name : qtchooser
Version : 26-3
Description : Wrap the other Qt tools by searching for different instances of Qt on the system
Architecture : x86_64
Licenses : GPL
Groups : None
Provides : None
Depends On : gcc-libs
Optional Deps : None
Required By : qt5-base
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 25.00 KiB
Packager : Andrea Scarpino <>
Build Date : Thu 11 Apr 2013 02:13:42 PM CEST
Install Date : Fri 12 Apr 2013 07:09:36 PM CEST
Install Reason : Installed as a dependency for another package
Install Script : No
Validated By : Signature

Steps to reproduce:

1. Install qtchooser
2. Open a terminal
3. Run qtconfig
4. See this:

% qtconfig
qtconfig: could not exec '/usr/lib/qt/bin/qtconfig': No such file or directory

Running /usr/lib/qt4/bin/qtconfig directly just works as expected (it opens a GUI for configuring Qt appeareance).

This task depends upon

Closed by  Andrea Scarpino (BaSh)
Tuesday, 16 April 2013, 22:26 GMT
Reason for closing:  Not a bug
Additional comments about closing:  qtchooser uses Qt5 by default, and Qt5 has no qtconfig tool
Comment by Jan de Groot (JGC) - Sunday, 14 April 2013, 10:01 GMT
I guess you don't understand how qtchooser works. By default it is configured for qt5, so if you don't have that, then it will call binaries that don't exist. Either you change the default.conf symlink in /etc/xdg/qtchooser, or you set QT_SELECT to 4 to select Qt4.
Comment by Andrea Scarpino (BaSh) - Monday, 15 April 2013, 10:02 GMT
This could even considered as a qtchooser bug. It shouldn't point to non-existent qt5 binaries (there's no qtconfig in qt5).

BTW, instread of the full path you could also use qtconfig-qt4.